summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorLauri Kenttä2017-08-28 22:50:14 +0300
committerLauri Kenttä2017-08-28 22:50:14 +0300
commite1e46a15aa96de847308b99c09bf1fe1e9c2d7a6 (patch)
treedaf93ebb36c7025d750fecb55144caeaccf313d4 /PKGBUILD
downloadaur-huawei-mobile-helper.tar.gz
Version 1.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD21
1 files changed, 21 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..341751584099
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: Lauri Kenttä <lauri.kentta@gmail.com>
+pkgname=huawei-mobile-helper
+pkgver=1.0
+pkgrel=1
+pkgdesc="Auto-connect for non-HiLink Huawei USB dongles"
+arch=('any')
+url="https://github.com/Metabolix/$pkgname"
+license=('GPL')
+depends=('udev' 'systemd' 'bash')
+source=("git+$url.git")
+sha1sums=(${source[@]/*/SKIP})
+
+pkgver() {
+ cd "$pkgname"
+ git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+package() {
+ cd "$pkgname"
+ sh install.sh "$pkgdir"
+}