summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authoraksel2021-01-26 12:46:45 +0100
committeraksel2021-01-26 12:46:45 +0100
commitede0a298dea19e2f0d20dc4232825591b1817168 (patch)
tree15834b769d59c868528b5345eabdeae70e7708e6 /PKGBUILD
downloadaur-hunspell-fo.tar.gz
hunspell-fo 0.4.2
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c0fb27553fb6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: aksel <aksel@akseltorgard.com>
+# Based on hunspell-* PKGBUILDs
+
+pkgname=hunspell-fo
+pkgver=0.4.2
+pkgrel=1
+pkgdesc="Faroese hunspell dictionaries"
+arch=('any')
+url="https://fo.speling.org/"
+license=('GPL2' 'LGPL2.1' 'MPL')
+optdepends=('hunspell: the spell checking libraries and apps')
+source=("${pkgname}-${pkgver}.tar.gz::https://fo.speling.org/filer/myspell-fo-${pkgver}.tar.gz")
+sha256sums=('SKIP')
+
+package() {
+ cd "$srcdir/myspell-fo-${pkgver}"
+ install -dm755 "${pkgdir}"/usr/share/hunspell
+ install -m644 fo_FO.dic fo_FO.aff $pkgdir/usr/share/hunspell
+
+ install -dm755 ${pkgdir}/usr/share/myspell/dicts
+ pushd "$pkgdir"/usr/share/myspell/dicts
+ for file in $pkgdir/usr/share/hunspell/*; do
+ ln -sv /usr/share/hunspell/"$(basename $file)" .
+ done
+ popd
+}