summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorViktor Drobot2019-12-02 13:44:52 +0300
committerViktor Drobot2019-12-02 13:44:52 +0300
commite49c3148d3a3391fa558942f579b55b2ec4bb733 (patch)
treebaa1de4a7cfedc81626e656169131f3c7b095c6c /PKGBUILD
downloadaur-hwloc1.tar.gz
First release
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD43
1 files changed, 43 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b2be0101b40b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: Viktor Drobot (aka dviktor) linux776 [at] gmail [dot] com
+# Contributor: Levente Polyak <anthraxx[at]archlinux[dot]org>
+# Contributor: Stéphane Gaudreault <stephane@archlinux.org>
+# Contributor: Sylvain HENRY <hsyl20@yahoo.fr>
+# Contributor: Hervé YVIQUEL <elldekaa@gmail.com>
+
+pkgname=hwloc1
+_pkgname=hwloc
+pkgver=1.11.13
+pkgrel=1
+pkgdesc='Portable Hardware Locality is a portable abstraction of hierarchical architectures (1.x branch)'
+url='https://www.open-mpi.org/projects/hwloc/'
+arch=('x86_64')
+license=('BSD')
+depends=('numactl' 'libtool' 'systemd-libs')
+makedepends=('cairo' 'libxml2' 'pciutils' 'systemd')
+optdepends=('cairo' 'libxml2' 'pciutils')
+conflicts=('hwloc')
+provides=("hwloc=${pkgver}")
+options=('!docs')
+source=(https://www.open-mpi.org/software/hwloc/v${pkgver%.*}/downloads/${_pkgname}-${pkgver}.tar.bz2)
+sha256sums=('a4494b7765f517c0990d1c7f09d98cb87755bb6b841e4e2cbfebca1b14bac9c8')
+
+build() {
+ cd hwloc-${pkgver}
+
+ ./configure \
+ --prefix=/usr \
+ --sbindir=/usr/bin \
+ --enable-plugins
+ make
+}
+
+check() {
+ cd hwloc-${pkgver}
+ make check
+}
+
+package() {
+ cd hwloc-${pkgver}
+ make DESTDIR="${pkgdir}" install
+ install -Dm 644 COPYING -t "${pkgdir}/usr/share/licenses/${_pkgname}"
+}