summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorVladimir Gorbunov2023-08-01 00:25:51 +0300
committerVladimir Gorbunov2023-08-01 00:25:51 +0300
commitfd8b6ae213ab6c7a618ec726162b5d6464abdc35 (patch)
tree7d8ea36ee19c4d7ba6f5ca21008590dc7f7a1821 /PKGBUILD
parent943d40fe9adec4cbfafcedf551d27b9e225636f0 (diff)
downloadaur-hy-git.tar.gz
Remove colorama and astor, set version, use python-installer
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 13 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e8290a0c68e4..1ee4ecf363dd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,14 @@
# Maintainer: Vladimir Gorbunov <truedaemon@gmail.com>
pkgname=hy-git
_gitname=hy
-pkgver=0.24.0.r7.gd175c5c7
+pkgver=0.27.0.r23.g2d6d5f9c
pkgrel=1
-pkgdesc="Python <--> Lisp layer"
+pkgdesc="A dialect of Lisp that's embedded in Python"
arch=('any')
url="http://hylang.org/"
license=('MIT')
-depends=('python-astor' 'python-colorama' 'python-funcparserlib')
-makedepends=('python-setuptools')
+depends=('python-funcparserlib')
+makedepends=('python-setuptools' 'python-build' 'python-wheel' 'python-installer')
conflicts=('hy')
provides=('hy')
options=(!emptydirs)
@@ -17,12 +17,19 @@ md5sums=("SKIP")
pkgver() {
cd "${_gitname}"
- git describe --long | sed -E 's/([^-]*-g)/r\1/;s/-/./g'
+ local version=$(git describe --long | sed -E 's/([^-]*-g)/r\1/;s/-/./g')
+ echo "__version__ = '${version}'" > hy/version.py
+ printf "%s" "$version"
+}
+
+build() {
+ cd "${_gitname}"
+ python -m build --wheel --no-isolation
}
package() {
cd "${_gitname}"
- python setup.py install --root="${pkgdir}/" --optimize=1
+ python -m installer --destdir="${pkgdir}/" dist/*.whl
install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
rm -rf "$pkgdir/usr/get_version"
}