summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorScore_Under2023-04-27 04:06:41 +0100
committerScore_Under2023-04-27 04:06:41 +0100
commit819138f168e95c6cf7d5c7672db44ace15c23072 (patch)
tree400630c162fe65ebe18846a69a38a6424fbe1e85 /PKGBUILD
parente8e870e6f2b0fa3d728f3b33a731051d9438e35f (diff)
downloadaur-hydrus-git.tar.gz
Update for v525a
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD39
1 files changed, 24 insertions, 15 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e5dcf092df6b..3b74617722a2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,34 +5,43 @@ DOC_DIRS=(opt/hydrus/help)
pkgname=hydrus-git
_pkgname=hydrus
-pkgver=476.r2.gd5166b4a
+pkgver=525a.r0.g2691a92c
pkgrel=1
pkgdesc="Danbooru-like image tagging and searching system for the desktop"
arch=(any)
-license=(WTFPL)
-install=hydrus.install
-provides=(hydrus)
-conflicts=(hydrus hydrus-docs hydrus-sources)
+license=(custom)
+provides=("hydrus=$pkgver" "hydrus-docs=$pkgver")
+conflicts=(hydrus hydrus-docs)
url=http://hydrusnetwork.github.io/hydrus/
depends=(python python-opencv python-beautifulsoup4 python-yaml
'python-lz4>=0.10.1' python-numpy python-twisted python-pillow
python-pysocks python-psutil python-send2trash python-html5lib
python-requests python-qtpy emoji-font python-mpv
- python-service-identity qt5-python-bindings fmt pyside2)
+ python-lxml python-urllib3 python-typing_extensions
+ python-service-identity # required by twisted for https hostname verification
+ pyside6)
makedepends=(git mkdocs mkdocs-material)
optdepends=('ffmpeg: show duration and other information on video thumbnails'
'miniupnpc: automatic port forwarding'
'desktop-file-utils: to add Hydrus to your desktop environment menus'
+ 'python-cbor2: cbor support in client-server communication'
+ 'python-chardet: detect text encoding more accurately'
'python-cloudscraper: bypass cloudflare "checking your browser" challenges'
- 'python-pyqt5-chart: display bandwidth usage charts'
- 'python-pyopenssl: to generate certificates for accessing client API and server via HTTPS')
-source=("git+https://github.com/hydrusnetwork/${_pkgname}.git"
+ 'python-dateutil: improved fuzzy date search'
+ 'python-pympler: debug menus to profile memory usage'
+ 'python-pyqt6-charts: display bandwidth usage charts'
+ 'python-cryptography: to generate certificates for accessing client API and server via HTTPS'
+ 'python-pyopenssl: to generate certificates for accessing client API and server via HTTPS'
+ # 'python-pyparsing: currently unused'
+ # 'speedcopy: may speed up file transfers'
+ 'swftools: to display SWF thumbnails')
+source=("${_pkgname}::git+https://github.com/hydrusnetwork/${_pkgname}.git"
paths-in-opt.patch
hydrus-client
hydrus-server
hydrus.desktop)
sha256sums=('SKIP'
- '6dde03b452b842d089cfdffb4cf8554b4985934d664054b2bb71006694f923c6'
+ 'b196485720ed874a22fe49a48ce92db423dda12824b2755071bbf47cfc891bc0'
'd2cb826ce0dd1892ab95fc3b14dbe6bd312210f653d0aea31938eeb7e361fdc5'
'463841cc16059b516cc327cfbc30d3383e2236b085ba2d503e82f5be39444806'
'9b8c2603a8040ae80152ff9a718ad3e8803fdc3029a939e3c0e932ea35ded923')
@@ -44,11 +53,7 @@ pkgver() {
prepare() {
cd "${srcdir}/${_pkgname}"
- git apply < ../paths-in-opt.patch
-
- # Remove unit tests
- rm -f "hydrus/Test"*.py
- rm -rf "static/testing"
+ patch -Np1 < ../paths-in-opt.patch
}
build() {
@@ -68,10 +73,14 @@ package() {
install -m755 -d "${pkgdir}/opt/hydrus"
cp -r help hydrus static client.pyw server.py "${pkgdir}/opt/hydrus/"
+ # Remove unit tests
+ rm -rf "${pkgdir}/opt/hydrus/hydrus/test" "${pkgdir}/opt/hydrus/static/testing"
+
# Create and populate /opt/hydrus/bin
install -d -m755 "${pkgdir}/opt/hydrus/bin"
ln -s /usr/bin/upnpc "${pkgdir}/opt/hydrus/bin/upnpc_linux"
ln -s /usr/bin/ffmpeg "${pkgdir}/opt/hydrus/bin/ffmpeg"
+ ln -s /usr/bin/swfrender "${pkgdir}/opt/hydrus/bin/swfrender_linux"
# Install hydrus-client and hydrus-server executables
install -d -m755 "${pkgdir}/usr/bin"