summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDaniel Bermond2024-05-03 18:17:11 -0300
committerDaniel Bermond2024-05-03 18:17:11 -0300
commitf04fb3fc55db7cc11ca90a060af3bc3ef8275b52 (patch)
tree3db659abdc9f227e52ebd5cd9cf4a63ea69e96bb /PKGBUILD
parent5b0290254d54f19544abbdeb4aaec65936eb9643 (diff)
downloadaur-i2pd-tools-git.tar.gz
Remove wrong executable files. Add i2pdctl. Update license.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 9 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1589cfc39bc9..20608ecb5200 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,22 +2,20 @@
pkgname=i2pd-tools-git
pkgver=r268.gcf0c9c9
-pkgrel=1
+pkgrel=2
pkgdesc='Useful tools for I2P (git version)'
arch=('x86_64')
url='https://github.com/PurpleI2P/i2pd-tools/'
-license=('BSD')
-depends=('boost-libs' 'openssl' 'zlib')
+license=('BSD-3-Clause')
+depends=('boost-libs' 'openssl' 'python' 'zlib')
makedepends=('git' 'boost')
provides=('i2pd-tools')
conflicts=('i2pd-tools')
source=('git+https://github.com/PurpleI2P/i2pd-tools.git'
'git+https://github.com/PurpleI2P/i2pd.git'
- '010-i2pd-tools-use-shared-lib.patch'
- '020-i2pd-tools-use-arch-flags.patch')
+ '010-i2pd-tools-use-arch-flags.patch')
sha256sums=('SKIP'
'SKIP'
- '340b85de6cc8f2bc33ca3c54b6d75ddcb9b4f009e600c2d783507926c29bfae8'
'fb2eba0fbc3a9ce5d39c099561bc56ba9f39dbed540b7f0fcd3377c426533300')
prepare() {
@@ -25,8 +23,9 @@ prepare() {
git -C i2pd-tools config --local submodule.i2pd.url "${srcdir}/i2pd"
git -C i2pd-tools -c protocol.file.allow='always' submodule update
- #patch -d i2pd-tools -Np1 -i "${srcdir}/010-i2pd-tools-use-shared-lib.patch"
- patch -d i2pd-tools -Np1 -i "${srcdir}/020-i2pd-tools-use-arch-flags.patch"
+ chmod a-x i2pd-tools/{*.{cpp,hpp,md},dependencies.sh,Makefile}
+
+ patch -d i2pd-tools -Np1 -i "${srcdir}/010-i2pd-tools-use-arch-flags.patch"
}
pkgver() {
@@ -42,7 +41,8 @@ package() {
while read -r -d '' _tool
do
install -D -m755 "$_tool" "${pkgdir}/usr/bin/i2pd-${_tool##*/}"
- done < <(find i2pd-tools -maxdepth 1 -type f ! -name '*.sh' ! -name '*README*' -executable -print0)
+ done < <(find i2pd-tools -maxdepth 1 -type f -executable -print0)
+ install -D -m755 i2pd-tools/scripts/i2pdctl -t "${pkgdir}/usr/bin"
install -D -m644 i2pd-tools/LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
}