summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorViachaslau Khalikin2020-02-22 10:19:25 +0300
committerViachaslau Khalikin2021-09-03 14:11:41 +0300
commite52468904a0cca621ec95d2773d10180b714f566 (patch)
tree5b3a351ffa29f5ca2dd7e34c9394c7e9be9b833f /PKGBUILD
parentf52deec2e38ae08c7c493f077071d7e574c21add (diff)
downloadaur-icecat-umatrix.tar.gz
bump to 1.4.4
change to build from sources add filetype in modeline
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 18 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f323cd8eaca6..5a90c82d3d3a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,30 @@
-# Maintainer: Viachaslau Khalikin <khalikin'at'yandex'dot'by>
+# Maintainer: Viachaslau Khalikin <khalikin@yandex.by>
pkgname=icecat-umatrix
-pkgver=1.4.0
+pkgver=1.4.4
pkgrel=1
pkgdesc='Point and click matrix to filter net requests by source, destination and type'
url=https://github.com/gorhill/uMatrix
arch=('any')
license=('GPL3')
groups=('icecat-addons')
-source=("https://github.com/gorhill/uMatrix/releases/download/${pkgver}/uMatrix.firefox.xpi")
-noextract=("${source##*/}")
-sha256sums=('8e00959b70ba6d676a63022594d4414ce6ea3a9d13bc3099f25d282a275fb160')
+makedepends=('git' 'python' 'strip-nondeterminism' 'zip')
+source=("git+$url.git#commit=$pkgver?signed"
+ "git+https://github.com/uBlockOrigin/uAssets.git")
+b2sums=('SKIP'
+ 'SKIP')
+validpgpkeys=('603B28AA5D6CD687A554347425E1490B761470C2') # Raymond Hill <rhill@raymondhill.net>
+
+build() {
+ cd uMatrix
+ ./tools/make-firefox.sh all
+ strip-nondeterminism -t zip dist/build/uMatrix.firefox.xpi
+}
package() {
- install -Dm644 "${source##*/}" "$pkgdir"/usr/lib/icecat/browser/extensions/uMatrix@raymondhill.net.xpi
+ cd uMatrix/dist/build
+ install -Dm644 uMatrix.firefox.xpi \
+ "$pkgdir"/usr/lib/icecat/browser/extensions/uMatrix@raymondhill.net.xpi
}
-# vim:set ts=2 sw=2 et:
+# vim:set ft=sh ts=2 sw=2 et: