summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorHector Mtz-Seara2016-03-15 15:39:51 +0100
committerHector Mtz-Seara2016-03-15 15:42:43 +0100
commit1cde257094218a7cb647e87e180a34268537a40b (patch)
treef51e695c6e43bc1f8b1c3aff8f96c6c8c8ca991d /PKGBUILD
parent4a617f772c3820dcad680c0313201b7d50c9fd0c (diff)
downloadaur-iep.tar.gz
Patched iep to avoid kernel SYN_flood false positive problem: iep-3.7-2
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 11 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1fd7a4ea7abb..890a424482b2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
#Contributor: Hector Mtz-Seara <hseara.#at#.gmail*.*com>
pkgname=iep
pkgver=3.7
-pkgrel=1
+pkgrel=2
pkgdesc="Pronounced as 'eep'is a cross-platform Python IDE focused on interactivity and introspection, which makes it very suitable for scientific computing. Its practical design is aimed at simplicity and efficiency."
url="http://iep-project.org"
license=("BSD")
@@ -14,8 +14,16 @@ optdepends=(
makedepends=('python-setuptools')
-source=("http://bitbucket.org/iep-project/iep/downloads/iep-${pkgver}.source.zip")
-sha1sums=('4c5251813934f876b8aca6f213e5ff36686174c4')
+source=("http://bitbucket.org/iep-project/iep/downloads/iep-${pkgver}.source.zip"
+ "SYN_flood.patch")
+
+sha1sums=('4c5251813934f876b8aca6f213e5ff36686174c4'
+ '037799e6b50934e1fca169af90fddc2f47799cc9')
+prepare(){
+ cp SYN_flood.patch ${srcdir}/${pkgname}-${pkgver}/iep/yoton
+ cd "${srcdir}/${pkgname}-${pkgver}"/iep/yoton
+ patch connection_tcp.py < SYN_flood.patch
+}
build(){
cd "${srcdir}/${pkgname}-${pkgver}"