summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMichal Wojdyla2021-10-23 18:17:27 +0200
committerMichal Wojdyla2021-10-23 18:17:27 +0200
commita8439e160bbe82faa32f58e633c16cb4dc6dc740 (patch)
treeba724383a133ad78927facb18ea9434ad823fe1d /PKGBUILD
parent8b2a7faf1c66177f8c238f493c35520b947b5002 (diff)
downloadaur-ig2atom-git.tar.gz
update
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 9 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index bbeaad4a8356..266f0a664846 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,14 @@
-# Maintainer: Ian Douglas Scott <ian@iandouglasscott.com>
+# Contributor: Ian Douglas Scott <ian@iandouglasscott.com>
pkgname=ig2atom-git
-pkgver=r14.d87652a
+pkgver=r20.83347ef
pkgrel=1
pkgdesc="Convert Instagram feed to atom"
arch=('any')
url="https://github.com/ids1024/ig2atom"
license=('MIT')
makedepends=('git')
-depends=('python')
-source=('git://github.com/ids1024/ig2atom.git')
+depends=('python-feedgenerator')
+source=('git+https://github.com/ids1024/ig2atom.git')
md5sums=('SKIP')
_gitname="ig2atom"
@@ -16,10 +16,14 @@ pkgver () {
cd $srcdir/$_gitname
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
+build() {
+ cd "$srcdir/$_gitname"
+ python setup.py build
+}
package() {
cd "$srcdir/$_gitname"
- python setup.py install --root="$pkgdir"
+ python setup.py install --root="$pkgdir" --optimize=1
install -Dm644 README.md "$pkgdir/usr/share/doc/$pkgname/README.md"
install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}