summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorZach Callear2020-03-28 08:58:13 -0600
committerZach Callear2020-03-28 09:03:33 -0600
commit4ac678bdcdefadcf4000bc44380e612201744688 (patch)
tree4a87e8b2e209e9cefc5ec6743c9054a18bc55f7a /PKGBUILD
parentf44054eecb9267f3e28acbc8a8e7f3a7f43a49e1 (diff)
downloadaur-imgmin-git.tar.gz
Fix unnecessary dependency on ImageMagick 7
Fix unnecessary and broken build dependency on ImageMagick 7, in that the build process was still searching for MagickWand-config, which is not available in the libmagick6 package.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD4
1 files changed, 2 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 192844b45c39..2ea1003876ff 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
_pkgname=imgmin
pkgname=$_pkgname-git
pkgver=1.1.r17.g3451031
-pkgrel=6
+pkgrel=7
pkgdesc="Automated lossy JPEG optimization"
arch=('i686' 'x86_64' 'armv7h' 'armv6h')
url="https://github.com/rflynn/imgmin"
@@ -28,7 +28,7 @@ prepare() {
#
# Previously it was possible to use the MagickWand-config script from ImageMagick 7, but it
# now hardcodes MagickWand-7 in its pkg-config call.
- sed -i 's~AC_CHECK_PROGS(MAGICK_CONFIG.*~AC_CHECK_PROG(MAGICK_CONFIG, MagickWand-config, PKG_CONFIG_PATH=/usr/lib/imagemagick6/pkgconfig pkg-config MagickWand)~g' configure.ac
+ sed -i 's~AC_CHECK_PROGS(MAGICK_CONFIG.*~AC_CHECK_PROG(MAGICK_CONFIG, pkg-config, PKG_CONFIG_PATH=/usr/lib/imagemagick6/pkgconfig pkg-config MagickWand)~g' configure.ac
sed -i 's~ --cppflags~ --cflags~g' src/Makefile.am src/apache2/Makefile.am
sed -i 's~ --ldflags~ --libs~g' src/Makefile.am src/apache2/Makefile.am