summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorwillemw122020-08-23 10:54:55 +0200
committerwillemw122020-08-23 10:54:55 +0200
commit512c8158d592d019afd36ee89f640f995a102402 (patch)
tree955818c7e9c27eb8e170dcb118edc7857667a39c /PKGBUILD
parent285dca166d24bbcf91f333af0b327c6821e73738 (diff)
downloadaur-indicator-weather-bzr.tar.gz
Update source URL
Add python-dulwich for Git support Remove .install file Install license first
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 7 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 98b7113f611d..d866efa0478c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,18 @@
# Maintainer: willemw <willemw12@gmail.com>
-_pkgname=indicator-weather
-pkgname=$_pkgname-bzr
+pkgname=indicator-weather-bzr
pkgver=r358
-pkgrel=3
+pkgrel=4
pkgdesc="Comprehensive weather notification system, implemented using the indicator applet API (Canonical Ayatana Project)"
arch=('any')
url="https://launchpad.net/weather-indicator"
license=('GPL3')
depends=('libappindicator-gtk3' 'libgweather' 'python2-pywapi' 'python2-pytz')
optdepends=('python2-unidecode: for ASCII transliterations of Unicode text')
-makedepends=('bzr' 'python2-distutils-extra')
-provides=($_pkgname)
-conflicts=($_pkgname)
-install=$pkgname.install
-source=($pkgname::bzr+http://bazaar.launchpad.net/~weather-indicator-team/weather-indicator/rainy) # Series 2.0
+makedepends=('bzr' 'python2-distutils-extra' 'python-dulwich')
+provides=("${pkgname%-bzr}")
+conflicts=("${pkgname%-bzr}")
+source=($pkgname::bzr+lp:weather-indicator)
md5sums=('SKIP')
pkgver() {
@@ -34,7 +32,7 @@ build() {
package() {
cd $pkgname
+ install -Dm644 AUTHORS "$pkgdir/usr/share/doc/indicator-weather/AUTHORS"
python2 setup.py install --root="$pkgdir" --optimize=1
- install -D -m644 AUTHORS "$pkgdir/usr/share/doc/indicator-weather/AUTHORS"
}