summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorRobert Pannick2024-02-13 13:13:06 -0500
committerb08x2024-02-13 13:13:06 -0500
commit94d97850813feb9e6dddabbe2a0675fe691d6f94 (patch)
treebab66330d5fdd29d2323bf3b5797ba932c0af114 /PKGBUILD
parent85314153d399e35d523221a74a0b0d4d01caba38 (diff)
downloadaur-ingen-git.tar.gz
update: cleanup declarations
https://gitlab.com/drobilla/ingen/-/commits/master/?ref_type=HEADS
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 5 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2e66f5ccdbc8..bb865a485cd2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,14 +3,14 @@
_pkgname=ingen
pkgname=$_pkgname-git
-pkgver=0.5.1.r3006.819fba38
+pkgver=0.5.1.r3029.85ad8074
pkgrel=1
pkgdesc='A modular plugin host for JACK and LV2 (git version)'
-arch=(x86_64)
+arch=('x86_64' 'x86_64_v3')
url='https://drobilla.net/software/ingen.html'
license=(GPL)
-depends=(gtkmm python-rdflib)
-makedepends=(boost ganv git jack lilv lv2 portaudio raul suil serd sord sratom)
+depends=('gtkmm' 'python-rdflib' 'cython')
+makedepends=('meson' 'boost' 'ganv' 'git' 'jack' 'lilv' 'lv2' 'portaudio' 'raul' 'suil' 'serd' 'sord' 'sratom' 'python-markdown' 'python-pygments' 'webkit2gtk')
provides=($_pkgname lv2-host)
conflicts=($_pkgname)
source=("${_pkgname}::git+https://gitlab.com/drobilla/ingen.git")
@@ -27,7 +27,7 @@ build() {
if [[ -d $pkgname-builddir ]]; then
arch-meson --reconfigure $pkgname-builddir $_pkgname
else
- arch-meson $pkgname-builddir $_pkgname
+ arch-meson --buildtype=release $pkgname-builddir $_pkgname
fi
meson compile -C $pkgname-builddir