summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMatthew Hiles2024-01-04 08:22:44 -0500
committerMatthew Hiles2024-01-04 08:22:44 -0500
commit0c92e843cc5bbe9e4052130546552aa7ea541e0d (patch)
tree53770f2e5e7abb610eac04bf93cbffa64b5212f8 /PKGBUILD
parent5186d7232ffa5a94ddc905ba932c4e41b550e6ac (diff)
downloadaur-inkscape-silhouette-git.tar.gz
update to use make install; add templates for standard full and half sheets (12in x 24in, 12in x 12in)
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 5 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8d4c120e3748..3f6da409cbce 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Matthew Hiles <matthew.hiles@gmail.com>
pkgname=inkscape-silhouette-git
-pkgver=r469.c3e1fa4
-pkgrel=2
+pkgver=r663.8128b6c
+pkgrel=1
pkgdesc="inkscape plugin to control Silhouette vinyl cutters"
arch=(any)
url="https://github.com/fablabnbg/inkscape-silhouette"
@@ -32,10 +32,12 @@ build() {
package() {
cd "$srcdir/${pkgname%-git}"
- #python setup.py install --root="$pkgdir/"
+ make DESTDIR="$pkgdir/" install
+ cp ../../*.svg "$pkgdir/usr/share/inkscape/templates/"
mkdir -p "$pkgdir/usr/share/inkscape/extensions/"
cp sendto_silhouette.* "$pkgdir/usr/share/inkscape/extensions/"
cp -R silhouette "$pkgdir/usr/share/inkscape/extensions/"
mkdir -p "$pkgdir/etc/udev/rules.d/"
cp silhouette-udev.rules "$pkgdir/etc/udev/rules.d/"
+ mv "$pkgdir/lib/" "$pkgdir/usr/"
}