summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorhaawda2021-11-28 14:56:49 +0100
committerhaawda2021-11-28 14:56:49 +0100
commit08a80380df5ecf51c1ffc4659630bbad16fb25ba (patch)
treec7b07a6fd1aa2535807d98338fde23d65d45d84d /PKGBUILD
parent85606a1e8a5f68d43099b3d8716620344669d5b0 (diff)
downloadaur-iscdcommons-git.tar.gz
manually install source files
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 5 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index dd8400463d22..be09dbdfbe64 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=iscdcommons-git
pkgver=20210723.r39
-pkgrel=3
+pkgrel=4
pkgdesc="Common library for ISCD tools, e.g. elastic"
arch=('x86_64')
url="https://github.com/ISCDtoolbox/Commons"
@@ -29,6 +29,8 @@ build() {
}
package() {
- cd ${pkgname%-git}/build
- install -Dm644 libCommons.so "$pkgdir"/usr/lib/libCommons.so
+ cd ${pkgname%-git}
+ install -Dm644 build/libCommons.so "$pkgdir"/usr/lib/libCommons.so
+ install -d "$pkgdir"/usr/share/include/${pkgname-git}
+ cp sources/*.c sources/*.h "$pkgdir"/usr/share/include/${pkgname-git}
}