summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorBruno Santos2021-05-29 12:37:03 +0100
committerBruno Santos2021-05-29 12:37:03 +0100
commit8f541e7abd2b6d7486ea8e9141cf08932743c87c (patch)
treed4ce831833e053b659ff0c43151008666bed2249 /PKGBUILD
parentdbd81f9d42664cb660cb00803dacb09bdca88f47 (diff)
downloadaur-ixxat-socketcan.tar.gz
Update for newer kernels
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 19 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e7c758a14a17..85b0dcb253db 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,9 @@
# Maintainer: Bruno Santos <brunomanuelsantos@tecnico.ulisboa.pt>
+# Patches taken from https://gitlab.com/bms-contrib/ixxat-socketcan
pkgname=ixxat-socketcan
pkgver=1.1.148.0
-pkgrel=6
+pkgrel=7
pkgdesc="SocketCAN driver for IXXAT USB-to-CAN v2"
arch=('i686' 'x86_64')
url="https://www.ixxat.com/products/products-industrial/pc-interfaces/pc-can-interfaces/socketcan"
@@ -11,17 +12,27 @@ makedepends=(linux-headers)
optdepends=('can-utils: Linux-CAN / SocketCAN user space applications')
install=$pkgname.install
source=('https://cdn.hms-networks.com/docs/librariesprovider8/ixxat-english-new/pc-can-interfaces/linux-drivers/socketcan-linux.zip?sfvrsn=3eb48d7_8'
- kernel_do_gettimeofday_fix.patch
- kernel_ioremap_nocache_fix.patch)
-md5sums=('4875b7dcfddfb76279ec61477765dd04'
- '918f3a220153599c2a4c3fad7de86cc1'
- '25ef511b0f11a7d84ce9ffc6020293c3')
+ 0.patch
+ 1.patch
+ 2.patch
+ 3.patch
+ 4.patch
+ 5.patch)
+sha256sums=('801558b4ef182548dfaa10a1cc65696f5c84caf6c8df98be8fa812c392b491a2'
+ '30993ecc5f97187f92ffaa1606a9cd588e1d0b7ab636bca8ba5ced3eb70b41d5'
+ '3389d2301e159e2c99452cd4a68a0050d30c74831edf51afedee7e46b3d005b6'
+ 'a8828fa152b80120ec529f4a862936747697a94ad6a2009aabb2951b0784a579'
+ '8eb368650f1b0e4340da7bd25dbd5b03843841cfb39bb7ec677eb11634fdabf1'
+ '61ed6b5afdbb057318bd415c2d9b9ea4719d1ced8b1d3f0dfb9a80930f4c741d'
+ 'e1cb2108dde3ed8c6498a1b501b46a93f1189fb715be2f0ac71a6b5080fdf64b')
_extramodules=$(uname -r)/extramodules
prepare() {
- patch -p1 -i kernel_do_gettimeofday_fix.patch
- patch -p1 -i kernel_ioremap_nocache_fix.patch
+ for patch in *.patch
+ do
+ patch -p1 -i $patch
+ done
}
build() {