summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorhaawda2019-10-12 14:03:49 +0200
committerhaawda2019-10-12 14:03:49 +0200
commit5a96b5b0ba813221cd0cd4e3ce06945fbcb73d82 (patch)
treeb7e711f972389cb35b8a602df9f13321d7a89f3f /PKGBUILD
parent5bdd150a9feec07de7bcaec29b61620561b1785c (diff)
downloadaur-5a96b5b0ba813221cd0cd4e3ce06945fbcb73d82.tar.gz
move the assemble part into prepare function
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 6 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5863c1f5cd76..4c3ef6e135a3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@
# installation.
pkgname=jabref-git
-pkgver=5.0alpha.r162.g74fb8bcbd3
+pkgver=5.0alpha.r269.g2e796e998a
pkgrel=1
pkgdesc="GUI frontend for BibTeX, written in Java -- built from git"
arch=('any')
@@ -30,9 +30,13 @@ pkgver() {
git describe --tags | sed 's+-alpha-+alpha.r+'|cut -c2-|tr - .
}
-build() {
+prepare() {
cd ${pkgname%-git}
./gradlew assemble
+}
+
+build() {
+ cd ${pkgname%-git}
./gradlew jlink
}