summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMaciej Dems2020-05-28 09:33:30 +0200
committerMaciej Dems2020-05-28 09:33:30 +0200
commit914e0fe1e21f90503bcc779a11fef587f10c0068 (patch)
treec6046a7f7cac8bc118db34c5a758b50e45025687 /PKGBUILD
parent33838ccecb35c151ebeee6d7de2ac8764e591f9b (diff)
downloadaur-jama.tar.gz
Patched TNT includes
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 9 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6e74a8d5c909..4adccde841e7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,15 +1,21 @@
# Maintainer: Maciej Dems <maciej.dems@p.lodz.pl>
pkgname=jama
pkgver=1.2.5
-pkgrel=1
+pkgrel=2
pkgdesc='C++ Linear Algebra Library based on TNT'
arch=(any)
url="http://math.nist.gov/tnt"
license=('custom')
-source=('https://math.nist.gov/tnt/jama125.zip')
-md5sums=('7a5acf6031cf35a6bb15a0fe1f70ed34')
+source=('https://math.nist.gov/tnt/jama125.zip' 'tnt-include-fix.patch')
+md5sums=('7a5acf6031cf35a6bb15a0fe1f70ed34'
+ '1d31f1962c081181a26033575a313dfc')
depends=('tnt')
+prepare() {
+ cd ${srcdir}
+ patch --forward --strip=1 --input="${srcdir}/tnt-include-fix.patch"
+}
+
package() {
cd ${srcdir}
install -d ${pkgdir}/usr/include/${pkgname}