summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorBenoit Favre2020-04-05 11:24:00 +0200
committerBenoit Favre2020-04-05 11:24:00 +0200
commit1933c653f66e1657c32519cd795f49006c3515be (patch)
tree4d171f8aaf616b72643902af5462e6c96b4b6bea /PKGBUILD
downloadaur-jazz-midi-plugin-bin.tar.gz
initial release
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7f473c8eeda1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Benoit Favre <benoit.favre@gmail.com>
+pkgname=jazz-midi-plugin-bin
+pkgver=1.5.2
+pkgrel=1
+epoch=
+pkgdesc="Jazz-Midi Plugin (support for midi in web browsers)"
+arch=(x86_64)
+url="https://jazz-soft.net/"
+license=('unknown')
+optdepends=(firefox chromium opera)
+source=("https://jazz-soft.net/download/Jazz-Plugin/1.5.1/Jazz-Plugin-1-5-2.sh")
+md5sums=('d6ccc8e27ac5121c8412f024ab61a407')
+
+build() {
+ echo $PWD
+ sh Jazz-Plugin-1-5-2.sh --noexec --keep --target ./extracted
+ # patch install file to copy content to pkg directory
+ # note that this approach does not account for spaces in install script / build dir
+ sed -i 's/\<sudo\>//;s/ \// $DESTDIR\//g' ./extracted/install.sh
+}
+
+package() {
+ cd ./extracted
+ export DESTDIR="$pkgdir/"
+ sh install.sh
+ # use the following command if you have spaces in your build dir
+ #proot sh install.sh
+}