summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorzxp198210052024-12-23 10:37:46 +0800
committerzxp198210052024-12-23 10:37:46 +0800
commit01f6875748ad6e063ad7c37293cd0f042d65bbcb (patch)
treeacfdb1be060fba54eeb5934433c3f5f30b6f10fc /PKGBUILD
parent2e4a36f0b269dfde55e8686722d153389aebc24f (diff)
downloadaur-jlivertool.tar.gz
update to 2.2.1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 8 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f1ae48120221..93397978a850 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,11 +1,11 @@
# Maintainer: zxp19821005 <zxp19821005 at 163 dot com>
pkgname=jlivertool
_pkgname=JLiverTool
-pkgver=2.2.0
+pkgver=2.2.1
_electronversion=26
_nodeversion=20
-pkgrel=2
-pkgdesc="Simple Bilibili Danmaku Tool.Use system-wide electron.Bilibili 弹幕机."
+pkgrel=1
+pkgdesc="Simple Bilibili Danmaku Tool.(Use system-wide electron)Bilibili 弹幕机."
arch=('x86_64')
url="https://github.com/Xinrea/JLiverTool"
license=('MIT')
@@ -26,7 +26,7 @@ source=(
"${pkgname}-${pkgver}.tar.gz::${url}/archive/refs/tags/v${pkgver}.tar.gz"
"${pkgname}.sh"
)
-sha256sums=('a862ac202ae0162c6b4d03b0da14eb3f54a19d86cfcbf5288ecea9e49bc7ba43'
+sha256sums=('04e9843806774f941e4962b4f582e7d689706afe36f812eac5dad19e175eb6db'
'291f50480f5a61bc9c68db7d44cd0412071128706baa868a9cb854f8779a1980')
_ensure_local_nvm() {
local NVM_DIR="${srcdir}/.nvm"
@@ -34,7 +34,7 @@ _ensure_local_nvm() {
nvm install "${_nodeversion}"
nvm use "${_nodeversion}"
}
-build() {
+prepare() {
sed -e "
s/@electronversion@/${_electronversion}/g
s/@appname@/${pkgname}/g
@@ -57,7 +57,6 @@ build() {
if [[ "$(curl -s ipinfo.io/country)" == *"CN"* ]]; then
{
echo 'registry=https://registry.npmmirror.com'
- echo 'disturl=https://registry.npmmirror.com/-/binary/node/'
echo 'electron_mirror=https://registry.npmmirror.com/-/binary/electron/'
echo 'electron_builder_binaries_mirror=https://registry.npmmirror.com/-/binary/electron-builder-binaries/'
} >> .npmrc
@@ -65,6 +64,9 @@ build() {
fi
sed -i "s/\"electron\": \"[^\"]*\"/\"electron\": \"${SYSTEM_ELECTRON_VERSION}\"/g;s/develop/${pkgver}/g" package.json
NODE_ENV=development npm install
+}
+build() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
NODE_ENV=production npx webpack
NODE_ENV=production npm exec -c "electron-builder build --linux dir -c.electronDist=${electronDist}"
}