summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorChristian Hesse2022-03-21 15:17:37 +0100
committerChristian Hesse2022-03-21 15:17:37 +0100
commit3a93c0b530d5db90c63169aad5bb5f70bd1d9c8d (patch)
tree04f0a4934a5c4daf199377096f65888cb9e8dc4e /PKGBUILD
parenteab6f8238fd2addc58a2036e7700f4e386e22f83 (diff)
downloadaur-journal-notify-git.tar.gz
commit journal-notify-git 0.1.2.r1.g9d2b0d8-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 10 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3372eca467c5..f47426da0a21 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,27 +1,32 @@
# Maintainer: Christian Hesse <mail@eworm.de>
pkgname=journal-notify-git
-pkgver=0.1.1.r12.ga1c0a5e
+pkgver=0.1.2.r1.g9d2b0d8
pkgrel=1
pkgdesc='Notify about journal log entries - git checkout'
arch=('i686' 'x86_64')
url='https://github.com/eworm-de/journal-notify'
depends=('libnotify' 'systemd')
optdepends=('gnome-icon-theme: icons in notifications')
-makedepends=('git' 'markdown')
+makedepends=('git' 'discount')
provides=('journal-notify')
conflicts=('journal-notify')
license=('GPL')
-source=('git://github.com/eworm-de/journal-notify.git')
+source=('git+https://github.com/eworm-de/journal-notify.git')
sha256sums=('SKIP')
pkgver() {
cd journal-notify/
if GITTAG="$(git describe --abbrev=0 --tags 2>/dev/null)"; then
- echo "$(sed -e "s/^${pkgname%%-git}//" -e 's/^[-_/a-zA-Z]\+//' -e 's/[-_+]/./g' <<< ${GITTAG}).r$(git rev-list --count ${GITTAG}..).g$(git log -1 --format="%h")"
+ printf '%s.r%s.g%s' \
+ "$(sed -e "s/^${pkgname%%-git}//" -e 's/^[-_/a-zA-Z]\+//' -e 's/[-_+]/./g' <<< ${GITTAG})" \
+ "$(git rev-list --count ${GITTAG}..)" \
+ "$(git rev-parse --short HEAD)"
else
- echo "0.r$(git rev-list --count master).g$(git log -1 --format="%h")"
+ printf '0.r%s.g%s' \
+ "$(git rev-list --count master)" \
+ "$(git rev-parse --short HEAD)"
fi
}