summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMike Sampson2015-06-21 20:13:21 +1000
committerMike Sampson2015-06-21 20:13:21 +1000
commitaffc511336106d1eb213e6c8b6dcfe22216431c6 (patch)
treeded46ccc285cf624b6a02ab6d0fe38ed4d458bc0 /PKGBUILD
downloadaur-jsonpipe-git.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD43
1 files changed, 43 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..60d578f28718
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: Mike Sampson <mike at sambodata dot com>
+pkgname=jsonpipe-git
+pkgver=20110412
+pkgrel=1
+pkgdesc="Convert JSON to a UNIX-friendly line-based format."
+arch=('any')
+url="https://github.com/zacharyvoase/jsonpipe"
+license=('CUSTOM')
+depends=('python2' 'python2-simplejson' 'python2-argparse' 'python2-calabash')
+makedepends=('git')
+
+_gitroot="https://github.com/zacharyvoase/jsonpipe.git"
+_gitname="jsonpipe"
+
+build() {
+ cd "$srcdir"
+ msg "Connecting to GIT server...."
+
+ if [ -d $_gitname ] ; then
+ cd $_gitname && git pull origin
+ msg "The local files are updated."
+ else
+ git clone $_gitroot $_gitname
+ fi
+
+ msg "GIT checkout done or server timeout"
+ msg "Starting make..."
+
+ rm -rf "$srcdir/$_gitname-build"
+ git clone "$srcdir/$_gitname" "$srcdir/$_gitname-build"
+ cd "$srcdir/$_gitname-build"
+
+ # Remove versioned dependencies. These are cutting edge even for Arch!
+ # Arch's versions seem to work fine.
+ #sed -i -e 's/>=2.1.3//' -e 's/>=1.2.1//' setup.py
+}
+
+package() {
+ cd "$srcdir/$_gitname-build"
+ python2 setup.py install --root=$pkgdir/ --optimize=1
+ install -d $pkgdir/usr/share/licenses/jsonpipe
+ install -m 644 -t $pkgdir/usr/share/licenses/jsonpipe/ UNLICENSE
+}