summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAndrea Feletto2020-09-01 16:53:05 +0200
committerAndrea Feletto2020-09-01 16:53:05 +0200
commit9b06ea0c92d75da24a8ff5036f9095f3024aa451 (patch)
tree56b618612db379b075e9d844527d4383cd629680 /PKGBUILD
downloadaur-9b06ea0c92d75da24a8ff5036f9095f3024aa451.tar.gz
version 0.4.1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD38
1 files changed, 38 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..587e12a2182c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# octave_kernel
+
+# Maintainer: Andrea Feletto <andrea@andreafeletto.com>
+
+pkgname=jupyter-gnuplot_kernel
+_pkgname=${pkgname#*-}
+pkgver=0.4.1
+pkgrel=1
+pkgdesc="A Jupyter kernel for GNUplot"
+arch=('any')
+url='https://github.com/has2k1/gnuplot_kernel'
+license=('BSD')
+depends=('jupyter-metakernel' 'jupyter-notebook' 'gnuplot')
+makedepends=('python-pip')
+source=("https://github.com/has2k1/${_pkgname}/archive/v${pkgver}.tar.gz")
+sha256sums=('bfc0e72556a32198b589ccfa97ed9575e31e2017f3f60b65a1b6d956bd1a7333')
+
+build() {
+ cd "$srcdir"/${_pkgname}-${pkgver}
+ python setup.py build
+}
+
+package() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+ python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+
+ while read -r Line; do
+ printf '%s\n' "$Line"
+ done <<-EOF
+ ##
+ ## please run:
+ ## $ python -m gnuplot_kernel install --user
+ ## after the installation.
+ ##
+ EOF
+}
+