summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorzxp198210052024-02-28 10:18:38 +0800
committerzxp198210052024-02-28 10:18:38 +0800
commiteddfc3c2fe56037f64e381370dae4bb663a74a82 (patch)
tree7594ec0cd8dc8afc8d919925dd178dfbb93ba318 /PKGBUILD
parent17944a14c79a17a996ef851801a135512ca73dec (diff)
downloadaur-kaiteki-bin.tar.gz
fix errors
Diffstat (limited to 'PKGBUILD')
-rwxr-xr-xPKGBUILD13
1 files changed, 3 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 637f0f025810..9011d463aaa4 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,24 +3,17 @@
pkgname=kaiteki-bin
_pkgname=Kaiteki
pkgver=2024_02
-pkgrel=2
+pkgrel=3
pkgdesc="A comfy Fediverse client for microblogging instances, made with Flutter and Dart. Currently with simple Mastodon, Pleroma, Misskey and Calckey support"
arch=('x86_64')
url='https://kaiteki.app'
_ghurl=https://github.com/Kaiteki-Fedi/Kaiteki
-license=('AGPL3')
+license=('AGPL-3.0-only')
conflicts=("${pkgname%-bin}")
provides=("${pkgname%-bin}=${pkgver}")
depends=(
'gtk3'
'libhandy'
- 'at-spi2-core'
- 'cairo'
- 'libepoxy'
- 'pango'
- 'gdk-pixbuf2'
- 'fontconfig'
- 'harfbuzz'
)
makedepends=(
'gendesk'
@@ -35,7 +28,7 @@ build() {
sed -e "s|@appname@|${pkgname%-bin}|g" \
-e "s|@runname@|${pkgname%-bin}|g" \
-i "${srcdir}/${pkgname%-bin}.sh"
- gendesk -q -f -n --categories "Network" --name "${_pkgname}" --exec "${pkgname%-bin} --no-sandbox %U" "${startdir}/PKGBUILD"
+ gendesk -q -f -n --categories="Network" --name="${_pkgname}" --exec="${pkgname%-bin} --no-sandbox %U" "${startdir}/PKGBUILD"
chmod 755 "${srcdir}/linux/${pkgname%-bin}"
}
package() {