summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorLEVAI Daniel2024-03-08 23:04:39 +0100
committerLEVAI Daniel2024-03-08 23:04:39 +0100
commit581b81f8d3e45247bf33bf3dd80540d53c048894 (patch)
tree5cf539a5a0dbf4e4c5ca8767db1a5e74808f0d2b /PKGBUILD
parenteb040e0430eff08f01caaae7640867beabe8362d (diff)
downloadaur-kc-full.tar.gz
Define _pkgname with the original name
And don't use $pkgbase.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 8 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a3705549a3df..fa3307b0d555 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Levai, Daniel <leva at ecentrum.hu>
-pkgbase='kc'
pkgname='kc-full'
+_pkgname='kc'
pkgver=2.5.3
pkgrel=1
pkgdesc="console-based password manager - YubiKey, scrypt, PCRE and readline support"
@@ -9,6 +9,7 @@ arch=('any')
url="https://github.com/levaidaniel/kc"
license=('BSD-2-Clause')
conflicts=('kc')
+provides=('kc')
depends=('libbsd>=0.2.0'
'libxml2>=2.6.0'
'openssl>=1.1.1'
@@ -18,19 +19,19 @@ depends=('libbsd>=0.2.0'
'pcre>=8.12'
'readline'
)
-source=("${pkgbase}-${pkgver}.tar.gz::https://github.com/levaidaniel/${pkgbase}/archive/refs/tags/${pkgver}.tar.gz")
+source=("${_pkgname}-${pkgver}.tar.gz::https://github.com/levaidaniel/${_pkgname}/archive/refs/tags/${pkgver}.tar.gz")
sha256sums=('593db34bf53ad9197c3ac1ffc3742dfc03a784862f0a5fadeda6b6d2ad287539')
build() {
- cd "${pkgbase}-${pkgver}"
+ cd "${_pkgname}-${pkgver}"
make HAVE_PCRE=y HAVE_LIBSCRYPT=y HAVE_YUBIKEY=y -f Makefile.linux
}
package() {
- cd "${pkgbase}-${pkgver}"
+ cd "${_pkgname}-${pkgver}"
make HAVE_PCRE=y HAVE_LIBSCRYPT=y HAVE_YUBIKEY=y -f Makefile.linux install DESTDIR="${pkgdir}/" PREFIX=/usr
- install -dm755 "${pkgdir}/usr/share/doc/${pkgname}"
- install -m644 'Changelog.md' -t "${pkgdir}/usr/share/doc/${pkgname}/"
- install -m644 'README.md' -t "${pkgdir}/usr/share/doc/${pkgname}/"
+ install -dm755 "${pkgdir}/usr/share/doc/${_pkgname}"
+ install -m644 'Changelog.md' -t "${pkgdir}/usr/share/doc/${_pkgname}/"
+ install -m644 'README.md' -t "${pkgdir}/usr/share/doc/${_pkgname}/"
}