summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorLukáš Jirkovský2018-02-03 20:29:33 +0100
committerLukáš Jirkovský2018-02-03 20:29:33 +0100
commit321a51ee4b5748ccd3a5be24f4550601ed9cd179 (patch)
tree407c69cef1be975421c74036886fb709d0286c72 /PKGBUILD
parentb22a8b122def5ff02376bf4a4d688164337fcf6c (diff)
downloadaur-kcm-wacomtablet.tar.gz
update to beta 2
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 7 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f4b627f7cd81..dda53c8856c8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,23 +3,20 @@
# Contributor: Dany Martineau <dany.luc.martineau at gmail.com>
# Contributor: Dylon Edwards <deltaecho@archlinux.us>
pkgname=kcm-wacomtablet
-pkgver=3.0.0~beta1
+pkgver=2.9.82
pkgrel=2
+epoch=1
pkgdesc="KDE GUI for the Wacom Linux Drivers"
arch=('i686' 'x86_64')
url="https://www.linux-apps.com/p/1127862/"
-license=('GPL2')
+license=('GPL')
depends=('plasma-framework' 'xf86-input-wacom')
-makedepends=('git' 'cmake' 'extra-cmake-modules' 'kdoctools' 'kdelibs4support' 'python')
-# https://quickgit.kde.org/?p=wacomtablet.git
-source=("https://dl.opendesktop.org/api/files/download/id/1466630714/114856-wacomtablet-${pkgver}.tar.xz")
-md5sums=('95d1d29063d6de2ab0881c33e8eacb05')
+makedepends=('git' 'cmake' 'extra-cmake-modules' 'kdoctools')
+source=("wacomtablet-$pkgver::git://anongit.kde.org/wacomtablet.git#tag=v${pkgver}")
+md5sums=('SKIP')
prepare() {
cd "$srcdir/wacomtablet-$pkgver"
-
- sed -i "s|(MacroOptionalAddSubdirectory)|(ECMOptionalAddSubdirectory)|" CMakeLists.txt
- sed -i "s|macro_optional_add_subdirectory|ECM_OPTIONAL_ADD_SUBDIRECTORY|" CMakeLists.txt
}
build() {
@@ -27,8 +24,7 @@ build() {
cmake . \
-DCMAKE_INSTALL_PREFIX=/usr \
- -DCMAKE_BUILD_TYPE=Release \
- -DKDE_INSTALL_USE_QT_SYS_PATHS=ON
+ -DCMAKE_BUILD_TYPE=Release
make
}