summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMartin T. H. Sandsmark2021-03-19 14:50:38 +0100
committerMartin T. H. Sandsmark2021-03-19 14:50:38 +0100
commite1b351e896db76ded7c722872f04c27ce1636ea1 (patch)
tree0fd34ea0322308c188c489b4a4910065df5a786f /PKGBUILD
parent4b53ae7c9ad817a7e5261b2b69cfc5b1be71aef8 (diff)
downloadaur-kde2-kio-sftp-kde4-git.tar.gz
new upstream
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 5 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7000c9adfc96..a496005028c7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@ pkgver=2.2.2.r18.f2e832e
pkgrel=1
pkgdesc="Backport of the KDE4 version of kio-sftp to KDE 2"
arch=(i686 x86_64)
-url="https://github.com/sandsmark/kde2-${_module}"
+url="https://invent.kde.org/sandsmark/kde2-kio-sftp"
license=("GPL2")
groups=(kde2)
depends=(kde2-kdelibs-git libssh)
@@ -16,12 +16,12 @@ conflicts=(kde2-${_module} kde2-kio-sftp)
options+=(libtool)
# Mirror
-source=("git+https://github.com/sandsmark/kde2-${_module}.git")
+source=("git+https://invent.kde.org/sandsmark/kde2-kio-sftp.git")
md5sums=('SKIP')
pkgver() {
- cd kde2-${_module}
+ cd kde2-kio-sftp
printf "2.2.2.r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
@@ -31,18 +31,16 @@ prepare() {
else
mkdir build
fi
-
- cd kde2-${_module}
}
build() {
cd build
- cmake "$srcdir"/kde2-${_module} -DCMAKE_INSTALL_PREFIX=/usr -DKDEDIR=/usr/
+ cmake "$srcdir"/kde2-kio-sftp -DCMAKE_INSTALL_PREFIX=/usr
make
}
package() {
cd build
make DESTDIR="$pkgdir/" install
- cd "$srcdir"/kde2-${_module}
+ cd "$srcdir"/kde2-kio-sftp
}