summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorarcan1s2015-06-08 19:56:24 +0300
committerarcan1s2015-06-08 19:56:24 +0300
commit2414bba0084b1e8361786e7b039f18985f1cb009 (patch)
tree0ce92fbbec97b080c97e70b344173c054cbf18f2 /PKGBUILD
downloadaur-kdeplasma-applets-usu-notifications.tar.gz
upload kdeplasma-applets-usu-notifications
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7e9e9248bc32
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Evgeniy "arcanis" Alexeev <arcanis.arch at gmail dot com>
+
+pkgname=kdeplasma-applets-usu-notifications
+_pkgname=usu-notifications
+pkgver=0.1.3
+pkgrel=1
+pkgdesc="lternative KDE notifications, based on QML and org.kde.notofications, but with more features"
+arch=('any')
+url="http://kde-apps.org/content/show.php/?content=158063"
+license=('GPL')
+depends=('kdebase-workspace')
+makedepends=('unzip')
+source=(http://kde-look.org/CONTENT/content-files/158063-${_pkgname}.plasmoid)
+install=${pkgname}.install
+md5sums=('70b3cb22f8f93613ce9952c31fd40592')
+
+package() {
+ cd "${srcdir}"
+
+ mkdir -p "${pkgdir}/usr/share/apps/plasma/plasmoids/${_pkgname}"
+ cp -r "${srcdir}/"{contents,platformcontents,metadata.desktop} \
+ "${pkgdir}/usr/share/apps/plasma/plasmoids/${_pkgname}/"
+ install -Dm644 "${srcdir}/metadata.desktop" \
+ "${pkgdir}/`kde4-config --prefix`/share/kde4/services/${_pkgname}.desktop"
+}