summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorNils B2016-07-13 11:41:52 +0200
committerNils B2016-07-13 11:41:52 +0200
commitd01609b0667041d11c6fa91edfb05e5041faf329 (patch)
treec8177f42c7cdbb154412ab8876cb407c168d18ba /PKGBUILD
parent4970b177295d82270f64de0ef7210ff45fa5797f (diff)
downloadaur-keepass-plugin-keechallenge.tar.gz
Update upstream to github
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 5 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 566b7c73c261..7b6fb8329097 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,15 +1,14 @@
# Maintainer: Nils Bars <arch@nbars.de>
pkgname=keepass-plugin-keechallenge
-pkgver=1.5.0
-pkgrel=1
+pkgver=1.5
+pkgrel=2
pkgdesc="A plugin that allows to use the yubikey HMAC-SHA1 challenge-response functionality in Keepass."
arch=('i686' 'x86_64')
-url="http://sourceforge.net/projects/keechallenge/"
+url="https://github.com/brush701/keechallenge"
license=('GPL2')
depends=('keepass' 'yubikey-personalization')
-_zipname="KeeChallenge_1.5"
-source=(http://sourceforge.net/projects/keechallenge/files/KeeChallenge/bin/${_zipname}.zip)
+source=(https://github.com/brush701/keechallenge/releases/download/${pkgver}/KeeChallenge_${pkgver}.zip)
build() {
cd ${srcdir}
@@ -17,7 +16,7 @@ build() {
}
package() {
- cd "${srcdir}/${_zipname}"
+ cd "${srcdir}/KeeChallenge_${pkgver}"
install -D -m 644 KeeChallenge.dll.config ${pkgdir}/usr/share/keepass/Plugins/KeeChallenge.dll.config
install -D -m 644 KeeChallenge.dll ${pkgdir}/usr/share/keepass/Plugins/KeeChallenge.dll
}