summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorfunilrys2018-08-23 19:04:57 +0200
committerfunilrys2018-08-23 19:04:57 +0200
commit9a5ccb15f9ad497d01aa73156694056c4e4c2906 (patch)
tree26b10c9852a21fa0d6304396d2f855e4518a0ba8 /PKGBUILD
parent63d4bb91ea86e7da9620074c7bc20be17edc055f (diff)
downloadaur-9a5ccb15f9ad497d01aa73156694056c4e4c2906.tar.gz
Fix build and install issues of keneric
Diffstat (limited to 'PKGBUILD')
-rwxr-xr-xPKGBUILD18
1 files changed, 11 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5041e7913a9e..5bc7e6aac2f7 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,14 +3,18 @@
pkgname=keneric
pkgver=0.3
-pkgrel=1
+pkgrel=2
+fullPkgName="174485-${pkgname}-${pkgver}"
pkgdesc='A generic thumbnailer for KDE'
arch=(i686 x86_64)
url='http://kde-apps.org/content/show.php/?content=174485'
license=(GPL)
depends=(kio)
makedepends=(extra-cmake-modules)
-source=("https://dl.opendesktop.org/api/files/download/id/1460971625/174485-$pkgname-$pkgver.tar.gz" stripPicture kenerickrita.desktop kenericblend.desktop)
+source=("${fullPkgName}.tar.gz::https://www.linux-apps.com/p/1080815/startdownload?file_id=1460971625&file_name=${fullPkgName}.tar.gz&file_type=application/x-gzip&file_size=469003&url=https%3A%2F%2Fdl.opendesktop.org%2Fapi%2Ffiles%2Fdownload%2Fid%2F1460971625%2Fs%2F2d7d5df9335cce0abe330a5e4449f05b%2Ft%2F1535045678%2Fu%2F%2F${fullPkgName}.tar.gz"
+ "stripPicture"
+ "kenerickrita.desktop"
+ "kenericblend.desktop")
sha512sums=('0c57621d3b74df9f059e10b217e2c471628ed69eed432f97026b39dc58e822721d69873fe8302e138d95538621820b851068d6dc6760cccbfb4a1f0b2a6682f7'
'8facba2194ff3677c652afaa559eb1e4f143d077a7202c454c950d409d6d378da85577f1dc5c2fd0e47937bf95f2b50f8659cdd5929cdea7a920c7b514618a29'
'9528a47faff250df9dd9ad6da699fc98aba77d7bc6e398f62aabf5a0c5ef2ae2d442438febe06f05b70258d12ae985fd8f99280e4b5ad44a5a79c4976e8e4b57'
@@ -22,7 +26,7 @@ prepare() {
build() {
cd build
- cmake ../$pkgname-$pkgver \
+ cmake ../${pkgname}-${pkgver} \
-DCMAKE_BUILD_TYPE=Release \
-DCMAKE_INSTALL_PREFIX=/usr \
-DBUILD_TESTING=OFF \
@@ -31,9 +35,9 @@ build() {
}
package() {
- make -C build DESTDIR="$pkgdir" install
+ make -C build DESTDIR="${pkgdir}" install
- mkdir -p "$pkgdir"/usr/{bin,share/kservices5}
- install -Dm755 stripPicture "$pkgdir"/usr/bin
- install -Dm644 *.desktop "$pkgdir"/usr/share/kservices5
+ mkdir -p "${pkgdir}"/usr/{bin,share/kservices5}
+ install -Dm755 stripPicture "${pkgdir}"/usr/bin
+ install -Dm644 *.desktop "${pkgdir}"/usr/share/kservices5
}