summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAntonio Rojas2023-11-10 09:12:41 +0100
committerAntonio Rojas2023-11-10 09:12:41 +0100
commit984b1629a902cee8ada511ab3c892bc7480338f1 (patch)
tree1e7af77e8e8a5c2062a966a7e5ee8b62669faadb /PKGBUILD
parent61d4b3c5b16ec6b517d66b6a7fb0c38d09b677d5 (diff)
downloadaur-keurocalc.tar.gz
Update KF5 dependencies
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 6 insertions, 13 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a3d61b787204..3b1028fef5a6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,28 +2,21 @@
pkgname=keurocalc
pkgver=1.3.0
-pkgrel=1
+pkgrel=2
pkgdesc="Utility to handle currency conversions between European currencies"
arch=(x86_64)
url="https://kde.org/applications/office/org.kde.keurocalc"
license=(GPL2)
-depends=(kio hicolor-icon-theme)
-makedepends=(extra-cmake-modules kdoctools)
+depends=(kio5 hicolor-icon-theme)
+makedepends=(extra-cmake-modules kdoctools5)
source=("https://download.kde.org/stable/$pkgname/$pkgname-$pkgver.tar.xz")
sha256sums=('964a9b358f77658b9776226c519b7aa10610fd6d8cdd8c53b8439a22cb93812a')
-prepare() {
- mkdir -p build
-}
-
build() {
- cd build
- cmake ../$pkgname-$pkgver \
- -DCMAKE_INSTALL_PREFIX=/usr
- make
+ cmake -B build -S $pkgname-$pkgver
+ cmake --build build
}
package() {
- cd build
- make DESTDIR="$pkgdir" install
+ DESTDIR="$pkgdir" cmake --install build
}