summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorArti Zirk2024-04-02 15:41:02 +0300
committerArti Zirk2024-04-02 15:41:02 +0300
commit6b38720eb95487a69eb02ad2e7e042a7c302c3bc (patch)
tree4c6fbfcc8ff2a310ff9b81f197fb885413537299 /PKGBUILD
parent28d40df6abf492a4e57e5e11658dc93645367a14 (diff)
downloadaur-keybase-zsh-completion-git.tar.gz
Update PKGBUILD
* Fixup provides and conflicts * For now install README.md into licenses folder as real LICENSE is missing
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD21
1 files changed, 10 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 47a783c99b50..fe9ba0c0962b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,18 @@
# Maintainer: Arti Zirk <arti.zirk@gmail.com>
-pkgname=keybase-zsh-completion-git
-pkgver=r5.4ec76d5
-pkgrel=1
+_pkgname="keybase-zsh-completion"
+pkgname="${_pkgname}-git"
+pkgver=r7.8e37ebf5fc2c
+pkgrel=2
pkgdesc="ZSH completion for keybase"
arch=('any')
url="https://github.com/fnoris/keybase-zsh-completion"
license=('MIT')
-groups=()
depends=('zsh')
makedepends=('git')
-provides=("${pkgname}")
-conflicts=("${pkgname}")
-replaces=()
-backup=()
-options=()
-install=
-source=('keybase-zsh-completion-git::git+https://github.com/fnoris/keybase-zsh-completion.git')
+provides=("${_pkgname}")
+conflicts=("${_pkgname}")
+source=("${pkgname}::git+https://github.com/fnoris/keybase-zsh-completion.git")
noextract=()
md5sums=('SKIP')
@@ -28,4 +24,7 @@ pkgver() {
package() {
cd "$srcdir/${pkgname}"
install -Dm644 _keybase "$pkgdir/usr/share/zsh/site-functions/_keybase"
+ # Upstream repo does not contain proper LICENSE file :(
+ install -Dm644 README.md "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+
}