summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAnatol Pomozov2015-06-17 08:47:11 -0700
committerAnatol Pomozov2015-06-17 08:47:11 -0700
commit2046790f8b3434571a003ca2f8faf00dc7c3997b (patch)
treeae8f52c7877d6216aea3b0cbe8ba6642de93bc36 /PKGBUILD
downloadaur-kgdb-agent-proxy.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fe4d01389121
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Anatol Pomozov <anatol dot pomozov at gmail>
+
+pkgname=kgdb-agent-proxy
+pkgver=1.96
+pkgrel=1
+pkgdesc='A simple, small proxy which was intended for use with kgdb, or gdbserver type connections where you want to share a text console and a debug session.'
+url='https://kgdb.wiki.kernel.org/index.php/Main_Page'
+arch=(i686 x86_64)
+depends=(glibc)
+makedepends=(git)
+license=(GPL2)
+source=(git://git.kernel.org/pub/scm/utils/kernel/kgdb/agent-proxy.git#tag=agent-proxy-$pkgver)
+sha1sums=('SKIP')
+
+build() {
+ cd agent-proxy
+ make
+}
+
+package() {
+ cd agent-proxy
+ install -d "$pkgdir"/usr/bin
+ install -m755 agent-proxy "$pkgdir"/usr/bin
+ install -D -m644 COPYING "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}