summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorCentRa2021-01-30 18:54:22 +0900
committerCentRa2021-01-30 18:54:22 +0900
commit951a5bf0f70ce61d124ce2b526a4d6f70ca4665a (patch)
tree6caa1a70ebb76b2190490f36b1f8738a9e9ec344 /PKGBUILD
parented2a6dd3fc259716f0bf76bcf15313c69d7b4d17 (diff)
downloadaur-kh-webstore.tar.gz
arewaeraw
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 8 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f0a2b68ad9e7..af902aabdfa5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -31,14 +31,19 @@ validpgpkeys=()
sudo chmod -R 777 ~/.cache/yay/kh-webstore/pkg
+prepare() {
+ rm -rf "/usr/share/kh-webstore"
+ rm -rf "/usr/share/applications/kh-webstore.desktop"
+}
+
build() {
- sudo cp -rf "$pkgname-$pkgver" "/usr/share/kh-webstore"
+ cp -rf "$pkgname-$pkgver" "/usr/share/kh-webstore"
cd "$pkgname-$pkgver"
- sudo cp -rf "kh-webstore.desktop" "/usr/share/applications/kh-webstore.desktop"
+ cp -rf "kh-webstore.desktop" "/usr/share/applications/kh-webstore.desktop"
}
package() {
- sudo rm /usr/share/applications/kh-webstore.desktop
+ rm /usr/share/applications/kh-webstore.desktop
mkdir $pkgdir/usr
mkdir $pkgdir/usr/share
mkdir $pkgdir/usr/share/applications