summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorCaleb Maclennan2024-04-27 23:04:42 +0300
committerCaleb Maclennan2024-04-27 23:04:42 +0300
commitcb9cb83a8052ee8e31425a6d3f1c5583d28193f8 (patch)
tree06dbb4b77151bd97855306a25bcfc2eea500684d /PKGBUILD
parent5497c814b544679f0a8497d7fca86f81f748cb21 (diff)
downloadaur-kindleunpack.tar.gz
upgpkg: kindleunpack 0.83-3
Rebuild for Python 3.12, cleanup packaging odds and ends
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 9 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4390bd3e9dc4..a4a5402a1c7f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,29 +5,31 @@ _pkgname=KindleUnpack
pkgname=${_pkgname,,}
pkgver=0.83
_pkgver=${pkgver/./}
-pkgrel=2
+pkgrel=3
pkgdesc='Extract text, images, and metadata from Kindle/Mobi files'
arch=(any)
url="https://github.com/kevinhendricks/$_pkgname"
-license=(GPL3)
-depends=(python-setuptools
+license=(GPL-3.0-only)
+depends=(python
tk)
+makedepends=(python-{build,installer,wheel}
+ python-setuptools)
_archive="$_pkgname-$_pkgver"
source=("$url/archive/v$_pkgver/$_archive.tar.gz"
- "Installing-with-setuptools.diff")
+ Installing-with-setuptools.diff)
sha256sums=('cd7a539573dedd1d78a6b49606446aa5a51acb520b4ee0ccb9f5b30deaddad2e'
'4c4eb18f9716875d90cf6c6b781ece9cbb316e2dcecebd2e89caec142bd25505')
prepare() {
cd "$_archive"
- patch -p1 < ../Installing-with-setuptools.diff
+ patch -p1 -i ../Installing-with-setuptools.diff
}
build() {
cd "$_archive"
- python setup.py build
+ python -m build -wn
}
package() {
cd "$_archive"
- python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+ python -m installer -d "$pkgdir" dist/*.whl
}