summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authoranthraxx2016-12-17 17:35:54 +0100
committeranthraxx2016-12-17 17:35:54 +0100
commitc4263c46162cbf3d069543a1ec4b624b72124292 (patch)
tree30f5cb03bf236cdc3f98bdfd3f825f985899ed3c /PKGBUILD
parent518746d363a0345bd641642ed8961374614ddb82 (diff)
downloadaur-kippo.tar.gz
upgpkg: kippo 0.9-4
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 10 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 769cc9186ee5..83477ac35889 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,18 +4,20 @@
pkgname=kippo
pkgver=0.9
-pkgrel=3
-pkgdesc="A medium interaction SSH honeypot designed to log brute force attacks and, most importantly, the entire shell interaction performed by the attacker"
-url="https://github.com/desaster/kippo"
+pkgrel=4
+pkgdesc='Medium interaction SSH honeypot designed to log brute force attacks and, most importantly, the entire shell interaction performed by the attacker'
+url='https://github.com/desaster/kippo'
arch=('any')
license=('BSD')
-depends=('twisted' 'python2-pycrypto' 'pyton2-zope-interface' 'python2-pyasn1')
+depends=('python2-twisted' 'python2-crypto' 'python2-zope-interface' 'python2-pyasn1')
backup=('etc/kippo.cfg')
install=kippo.install
source=(${pkgname}-${pkgver}.tar.gz::https://github.com/desaster/kippo/archive/v${pkgver}.tar.gz
- kippo.service)
+ kippo.service
+ INSTALL)
sha512sums=('0e17c410ecb8e44ba3862f0bd6c2773d6fa768750d7917ba7f5fbfdec8ddfa63fbde0e0190bcd5361a6c5ea0bcb2017e24593c4181b5cb915a605723bce07a26'
- 'f815717a2abb7abf548e229be83f62d166f039e9018c30f6a1d47c48dfafe5d6bb417b046e3d5056ac69e6791fb26ba04f20718fa3593f77e41c09d1830ebb42')
+ 'f815717a2abb7abf548e229be83f62d166f039e9018c30f6a1d47c48dfafe5d6bb417b046e3d5056ac69e6791fb26ba04f20718fa3593f77e41c09d1830ebb42'
+ 'fd82f060af248b413e62d779a4a20c6d6f4972cc724503a8c60fe435955ad7b1829caf9b5a8ceca41a2d9cf02144ab9fa9d892b59012e52a81d9dbfa832d4106')
prepare() {
cd ${pkgname}-${pkgver}
@@ -38,11 +40,11 @@ package() {
"${pkgdir}/usr/lib/systemd/system/kippo.service"
find . -type f -not \( -name kippo.cfg.dist -o -name start.sh -o -name stop.sh \) \
- -exec install -Dm 644 {} "${pkgdir}/opt/kippo/{}" \;
+ -exec install -Dpm 644 {} "${pkgdir}/opt/kippo/{}" \;
install -Dm 644 doc/COPYRIGHT "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
install -Dm 644 doc/README "${pkgdir}/usr/share/doc/${pkgname}/README"
- install -Dm 644 ../INSTALL "${pkgdir}/usr/share/doc/${pkgname}/INSTALL"
+ install -Dm 644 "${srcdir}/INSTALL" "${pkgdir}/usr/share/doc/${pkgname}/INSTALL"
}
# vim: ts=2 sw=2 et: