summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authororhun2020-07-30 02:01:43 +0300
committerorhun2020-07-30 02:01:43 +0300
commitb6c51bc79d74397ab05f6c9bbaf997ade4174575 (patch)
treede1062f37cbe60a1b2c7df0cddb3fdee33cfa77e /PKGBUILD
parent3623fd7424751f63c9fb1de25c702a7468b85407 (diff)
downloadaur-kmon.tar.gz
Update PKGBUILD about package source
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 7 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c1f504c36ea3..e4cbca550fa9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,23 +7,24 @@ arch=('i686' 'x86_64' 'armv6h' 'armv7h')
url="https://github.com/orhun/kmon"
license=('GPL3')
depends=('libxcb')
-makedepends=('cargo' 'python')
+makedepends=('cargo' 'python' 'git')
options=('zipman')
-source=("$pkgname-$pkgver.tar.gz::https://github.com/orhun/kmon/archive/v$pkgver.tar.gz")
-sha512sums=('fa44d73e3071e6699ea667c43646ac870068e6770aa881462bc8a78ab5a7c939b2247fab7fdf995c36a252b6d111cd6ecc633df6b6a86e58bd55a623699ebf27')
+source=("git+${url}.git#tag=v$pkgver?signed")
+sha512sums=('SKIP')
+validpgpkeys=('39E678DF63BE20EA5A175156B928720AEC532117') # orhun <orhunparmaksiz@gmail.com>
build() {
- cd "$pkgname-$pkgver"
+ cd "$pkgname"
cargo build --release --locked --all-features
}
check() {
- cd "$pkgname-$pkgver"
+ cd "$pkgname"
cargo test --release --locked
}
package() {
- cd "$pkgname-$pkgver"
+ cd "$pkgname"
install -Dm 755 "target/release/$pkgname" -t "$pkgdir/usr/bin"
install -Dm 644 README.md -t "$pkgdir/usr/share/doc/$pkgname"
install -Dm 644 "man/$pkgname.8" -t "$pkgdir/usr/share/man/man8"