summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorp4ck3t02022-05-24 13:57:13 +0200
committerp4ck3t02022-05-24 13:57:13 +0200
commitad4a833276c7175d3ffeec9589122e69b2a56fe9 (patch)
tree673c59a16899a71650336409329a4fc1baa7ceb5 /PKGBUILD
downloadaur-kns.tar.gz
Kubernetes Namespace Switcher version 1.0.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 18 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fabb33f957d9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,18 @@
+# Maintainer: p4ck3t0 <aur@p4ck3t0.de>
+
+pkgname=kns
+pkgver=1.0
+pkgrel=0
+pkgdesc="kns is a very small shellscript that utilizes fzf to switch between Kubernetes namespaces blazing fast."
+arch=('x86_64' 'aarch64' 'arm' 'armv6h' 'armv7h')
+url='https://github.com/blendle/kns'
+license=('ISC')
+provides=('kns')
+depends=('fzf')
+sha256sums=('1c5a786767cf7d4313f805e17efaf83ad40d1e6a9ac5ce82ca648c7887a36056')
+
+source=('https://raw.githubusercontent.com/blendle/kns/master/bin/kns')
+
+package() {
+ install -Dm 755 "${srcdir}/kns" "${pkgdir}/usr/bin/kns"
+}