summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorManuel Reimer2018-12-25 16:55:23 +0100
committerManuel Reimer2018-12-25 16:55:23 +0100
commita4ecf2200d1a03df3dd13d3451d4eff0035e663e (patch)
tree558457f5ec451ab23dfa1a3183a0270357299206 /PKGBUILD
downloadaur-kodi-setwakeup.tar.gz
Sync from VDR4Arch (https://github.com/VDR4Arch/vdr4arch/commit/40c5e4ae6a68f79dc39eef2e47c4de0745b354d3)
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ca6e99c7e182
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# This PKGBUILD is part of the VDR4Arch project [https://github.com/vdr4arch]
+
+# Maintainer: Manuel Reimer <manuel.reimer@gmx.de>
+pkgname=kodi-setwakeup
+pkgver=1.0.1
+pkgrel=1
+pkgdesc="Helper binary to call kodi setwakeup.sh with root privileges"
+url="https://github.com/VDR4Arch/vdr4arch"
+arch=('x86_64' 'i686' 'arm' 'armv6h' 'armv7h')
+license=('GPL3')
+depends=('kodi-standalone-service')
+makedepends=()
+source=('kodi-setwakeup.c'
+ 'setwakeup.sh')
+md5sums=('45e179324952f5aba8980e8dad7e91be'
+ '333278349fb355c01323f42b8105f333')
+
+build() {
+ gcc -o kodi-setwakeup kodi-setwakeup.c
+}
+
+package() {
+ install -Dm754 kodi-setwakeup "$pkgdir/usr/bin/kodi-setwakeup"
+ chgrp 420 "$pkgdir/usr/bin/kodi-setwakeup"
+ chmod u+s "$pkgdir/usr/bin/kodi-setwakeup"
+
+ install -Dm755 setwakeup.sh "$pkgdir/usr/lib/kodi/bin/setwakeup.sh"
+}