summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAndrey Kolchenko2021-12-10 14:28:14 +0300
committerAndrey Kolchenko2021-12-10 14:28:14 +0300
commite6acdffda35ae22e8339522c45faafbabaa797fd (patch)
tree00ea203e25205b282926fbb6e5dbb9afe02663aa /PKGBUILD
parent37636e5c4e01cce6e56ebb326e2d69bd561c0751 (diff)
downloadaur-kontur-diag-plugin.tar.gz
Update version to 3.1.0.210
Fetch file from API and use RPM format.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 8 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 00871b6da3a2..d612bd11debd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,22 @@
# Maintainer: Lionel Miller <delonorm at gmail dot com>
+# Maintainer: Andrey Kolchenko <andrey@kolchenko.me>
pkgname=kontur-diag-plugin
-pkgver=3.1.0.188
+pkgver=3.1.0.210
pkgrel=1
pkgdesc="Diag.Plugin is an extension for web browsers that allows users to install cryptographic programs for SKB Kontur services."
arch=('x86_64')
-_filename="diag.plugin_amd64.000797.deb"
license=('proprietary')
depends=(
'gtk3'
)
+makedepends=('findutils' 'grep' 'sed' 'coreutils')
url="https://help.kontur.ru/"
-source=("https://help.kontur.ru/files/$_filename")
-sha512sums=('a9c981ede9416e605df8ff67b136ace3300c0b7bc1df01a43d319ceaea1877136cb0e8ddcaf5f9ff9df73dbec51d26bdd049f63a55a01ee2f4c8d3d703afe412')
+source=("https://api.kontur.ru/drive/v1/public/diag/files/diag.plugin-${pkgver}-1.x86_64.000865.rpm")
+sha256sums=('bd5070f3a3ee21456fe378480f353f4457089f88e69efc47ed48de9100052ebf')
package() {
- bsdtar -xf data.tar.xz -C "$pkgdir/"
- rm -r "$pkgdir/usr/lib64/" # /usr/lib64 is a symlink to /usr/lib
+ find "${srcdir}" -type f | grep -v lib64 | sed -e "s#${srcdir}/##g" | xargs -I{} install -Dvm644 "${srcdir}/{}" "${pkgdir}/{}"
+ find "${pkgdir}/opt" -type f | xargs chmod 755
}
+