summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMartiMcFly2018-05-31 00:40:18 +0200
committerMartiMcFly2018-05-31 00:40:18 +0200
commit2dcc6d4a47382cb10c5a46ccc274314ec944846a (patch)
tree7a6acc4f918d74a4ef42297608570e2994b0e9bc /PKGBUILD
downloadaur-kopano-service-overview.tar.gz
init
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD42
1 files changed, 42 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..61783561ba25
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: MartiMcFly <martimcfly [at] autorisation.de>
+
+pkgname=('kopano-service-overview')
+replaces=("zarafa-service-overview")
+groups=('kopano')
+pkgver=1.0.2
+pkgrel=1
+pkgdesc='Kopano service overview'
+arch=('any')
+url='http://www.pietma.com/'
+license=('AGPL3')
+depends=('php'
+ 'php-fpm')
+source=('quicksand.ttf'
+ 'index.php'
+ 'kopano-service-overview.conf'
+ 'nginx-location.conf'
+ 'nginx-ssl.example.conf'
+ 'mozilla-account-configuration.php')
+md5sums=('SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP')
+
+package() {
+ cd ${srcdir}
+
+ mkdir -p ${pkgdir}/etc/php/fpm.d
+ cp ${srcdir}/${pkgname}.conf ${pkgdir}/etc/php/fpm.d
+
+ mkdir -p ${pkgdir}/etc/webapps/${pkgname}/
+ cp ${srcdir}/nginx-ssl.example.conf ${pkgdir}/etc/webapps/${pkgname}/
+ cp ${srcdir}/nginx-location.conf ${pkgdir}/etc/webapps/${pkgname}/
+
+ mkdir -p ${pkgdir}/usr/share/webapps/${pkgname}/
+ cp quicksand.ttf ${pkgdir}/usr/share/webapps/${pkgname}/
+ cp index.php ${pkgdir}/usr/share/webapps/${pkgname}/
+ cp mozilla-account-configuration.php ${pkgdir}/usr/share/webapps/${pkgname}/
+}
+