summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorsl1pkn072016-01-05 18:12:52 +0100
committersl1pkn072016-01-05 18:13:08 +0100
commitf007e422eb7a8a4d5afcb09158585da955b28290 (patch)
treec92085baea25579761dabb6e22ce5edeab02704d /PKGBUILD
parent04721bbb7f0c4e52fea07a2aa9fb5f0956f960af (diff)
downloadaur-kqoauth-git.tar.gz
Drop Qt4 version
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD36
1 files changed, 9 insertions, 27 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 99425bfde25a..567de69172d1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,55 +1,37 @@
# Maintainer: Gustavo Alvarez <sl1pkn07@gmail.com>
-pkgbase=kqoauth-git
-pkgname=('kqoauth-qt4-git' 'kqoauth-qt5-git')
+pkgname=kqoauth-git
pkgver=0.98.6.g7c31a12
pkgrel=1
pkgdesc="A library written in C++ for Qt that implements the OAuth 1.0 authentication specification RFC 5849. (GIT version)"
arch=('i686' 'x86_64')
url='https://github.com/kypeli/kQOAuth'
license=('LGPL2.1')
-makedepends=('qt5-base'
- 'qt4'
- )
+depends=('qt5-base')
+provides=('kqoauth')
+conflicts=('kqoauth')
source=('kqoauth::git+https://github.com/kypeli/kQOAuth.git')
sha1sums=('SKIP')
pkgver() {
cd kqoauth
- echo "$(git describe --long --tags |tr - .)"
+ echo "$(git describe --long --tags | tr - .)"
}
prepare(){
- mkdir -p build-qt{4,5}
+ mkdir -p build
}
build() {
- cd build-qt4
- qmake-qt4 ../kqoauth
- make
- cd ../build-qt5
+ cd build
qmake-qt5 ../kqoauth
make
}
-package_kqoauth-qt4-git() {
- pkgdesc="A library written in C++ for Qt that implements the OAuth 1.0 authentication specification RFC 5849. Qt4 Build. (GIT version)"
- depends=('qt4')
- provides=('kqoauth-qt4')
- conflicts=('kqoauth-qt5')
- make -C build-qt4 INSTALL_ROOT="${pkgdir}" install
-
- # Drop QMAKE_PRL_BUILD_DIR because reference the build dir
- find "${pkgdir}/usr/lib" -type f -name '*.prl' -exec sed -i -e '/^QMAKE_PRL_BUILD_DIR/d' {} \;
-}
-package_kqoauth-qt5-git() {
- pkgdesc="A library written in C++ for Qt that implements the OAuth 1.0 authentication specification RFC 5849. Qt5 Build. (GIT version)"
- depends=('qt5-base')
- provides=('kqoauth-qt5')
- conflicts=('kqoauth-qt4')
- make -C build-qt5 INSTALL_ROOT="${pkgdir}" install
+package() {
+ make -C build INSTALL_ROOT="${pkgdir}" install
# Drop QMAKE_PRL_BUILD_DIR because reference the build dir
find "${pkgdir}/usr/lib" -type f -name '*.prl' -exec sed -i -e '/^QMAKE_PRL_BUILD_DIR/d' {} \;