summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authormsmol2022-03-03 20:44:15 -0500
committermsmol2022-03-03 20:45:42 -0500
commitad4f80f0bd086dd183c57d728570c635228ac2b4 (patch)
tree2aea3c7e615f7e25a278581323299349a7ad43b7 /PKGBUILD
downloadaur-krunner-pass-wl-clipboard-git.tar.gz
Initial commit; add PKGBUILD
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..298e03d594d6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: msmol <mitch@smolash.com>
+# Contributor: Stuart Mumford <stuart@cadair.com>
+pkgname=krunner-pass-wl-clipboard-git
+pkgver=1.3.0
+pkgrel=1
+pkgdesc="krunner-pass patched to use wl-clipboard"
+arch=('any')
+url="https://github.com/akermu/krunner-pass"
+license=('GPL')
+depends=('krunner' 'qt5-base' 'ki18n' 'wl-clipboard')
+makedepends=('cmake' 'extra-cmake-modules')
+provides=('krunner-pass')
+source=("git://github.com/akermu/krunner-pass")
+md5sums=('SKIP')
+
+build() {
+ sed -i 's/cb->setText(msg)/QProcess::execute("wl-copy " + msg)/g' krunner-pass/pass.cpp
+ sed -i 's/cb->setText(QString())/QProcess::execute("wl-copy \" \"")/g' krunner-pass/pass.cpp
+ sed -i 's/kcmutils_version.h/\/usr\/include\/KF5\/KCMUtils\/kcmutils_version.h/' krunner-pass/config.cpp
+ mkdir -p build
+ cd build
+ cmake ../krunner-pass -DCMAKE_INSTALL_PREFIX=`kf5-config --prefix` -DQT_PLUGIN_INSTALL_DIR=`kf5-config --qt-plugins` -DCMAKE_BUILD_TYPE=Release
+ make
+}
+
+package() {
+ cd build
+ make install DESTDIR="${pkgdir}"
+}
+