summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorLlewelyn Trahaearn2023-12-18 09:36:42 -0800
committerLlewelyn Trahaearn2023-12-18 09:36:42 -0800
commitf45e94853da1830fc483677786bae0785acf9e2b (patch)
treef79890d370ea34f9c4f24b54177ab300ad1b12bc /PKGBUILD
parent853a8e5345dbc0addf9e575962a9e87fd24c10ee (diff)
downloadaur-ladish.tar.gz
Update to 1.1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD47
1 files changed, 17 insertions, 30 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7711576fe6a0..4e359b02626b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,43 +1,30 @@
# Maintainer: WoefulDerelict <WoefulDerelict at GMail dot com>
pkgname=ladish
-pkgver=1
-pkgrel=2
+pkgver=1.1
+pkgrel=1
pkgdesc="Session management system for JACK."
arch=('i686' 'x86_64')
-url="https://github.com/LADI/ladish"
-license=('GPL2')
-depends=('a2jmidid' 'boost' 'dbus-glib' 'flowcanvas<=0.7.1' 'jack' 'laditools' 'python2')
-makedepends=('git' 'intltool')
+url="https://ladish.org"
+license=('GPL2' 'custom:AFL2.1')
+depends=('a2jmidid' 'cdbus' 'dbus-glib' 'dbus-python' 'expat' 'glibc' 'gtkmm' 'jack2-dbus' 'libgnomecanvasmm' 'python' 'util-linux-libs')
+makedepends=('boost' 'git' 'intltool')
+optdepends=('laditools: Provides ladi-control-center the default JACK configuration tool in gladish')
provides=('lash')
conflicts=('lash')
-source=("https://github.com/LADI/ladish/archive/ladish-1.tar.gz"
- "ladish_conf.diff")
-sha512sums=('b01e24cd79c2711139c9d46c9bff4687049c3a735562a7f48a387103eec25c0222e935b90fb4eb2d3fc24629e417dab0c5aac215cbbca659ac49a2e802d1fd10'
- '8a5a937614a35ecfd1855e9fbe6325b86871a662cd771993eaae89f9b95b229469d939675284ef530cfc38acbfa2b674d094400b0aa793cbbf1fdce119fa4fae')
-
-prepare() {
- cd "${pkgname}-${pkgname}-${pkgver}"
- sed -i "s|env python|&2|" ladish_control
-
- # Add missing include.
- sed -i "36i#include <sys/resource.h>" daemon/loader.c
-
- # Fix default JACK conf tool.
- patch -Np1 -i ${srcdir}/ladish_conf.diff
-}
+source=("git+https://gitea.ladish.org/LADI/ladish.git#tag=${pkgver}")
+sha256sums=('SKIP')
build() {
- cd "${pkgname}-${pkgname}-${pkgver}"
- export PYTHON=/usr/bin/python2
- export CXX='g++ -std=c++11'
- python2 waf configure --prefix=/usr \
- --enable-liblash \
- --enable-pylash
- python2 waf
+ cd "${pkgname}"
+ ./waf configure --prefix=/usr \
+ --enable-gladish \
+ --enable-liblash
+ ./waf
}
package() {
- cd "${pkgname}-${pkgname}-${pkgver}"
- python2 waf install --destdir="${pkgdir}/"
+ cd "${pkgname}"
+ ./waf install --destdir="${pkgdir}"
+ install -Dm644 afl21.txt "$pkgdir/usr/share/licenses/$pkgname/AFL-2.1.txt"
}