summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorTatsuyuki Ishi2023-03-19 19:15:29 +0900
committerTatsuyuki Ishi2023-03-19 19:15:29 +0900
commit65b3017db6ed489dc70a87f7f8c7fc9dbf91bb65 (patch)
tree8a98243fb124921f689cba84fe4fc02a4993d714 /PKGBUILD
parentd0736790adb63c44a62ed28ddae78d2459fdee7d (diff)
downloadaur-latencyflex-git.tar.gz
Fix submodule breakage with Git security policy update.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 14 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0a41a8738786..3f91dcc2d760 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,10 @@
# Maintainer: Tatsuyuki Ishi <ishitatsuyuki@gmail.com>
# Contributor: Torge Matthies <openglfreak@googlemail.com>
+# Contributor: TheBill2001 <tuantran1632001@gmail.com>
_pkgname=latencyflex
pkgname=(latencyflex-git latencyflex-wine-git)
-pkgver=r40.9c2836f
+pkgver=r61.0470806
pkgrel=1
pkgdesc="Vendor and game agnostic latency reduction middleware"
arch=('x86_64')
@@ -13,10 +14,14 @@ makedepends=('git' 'cmake' 'meson' 'vulkan-headers' 'vulkan-validation-layers' '
source=("git+https://github.com/ishitatsuyuki/LatencyFleX.git"
"git+https://github.com/kubo/funchook.git"
"git+https://github.com/gdabah/distorm.git"
+ "git+https://android.googlesource.com/platform/external/perfetto"
+ "git+https://github.com/ishitatsuyuki/unhollowed-assemblies.git"
"latencyflex-wine.install")
sha256sums=('SKIP'
'SKIP'
'SKIP'
+ 'SKIP'
+ 'SKIP'
'30861957636eed47ee70461dc377e8dcd23b1acfa8b7bb570196e1347d121bb6')
_vcsname=LatencyFleX
@@ -29,12 +34,15 @@ pkgver() {
prepare() {
cd "$srcdir/$_vcsname"
- git submodule init layer/subprojects/funchook
- git config submodule.layer/subprojects/funchook.url "$srcdir/funchook"
- git submodule update layer/subprojects/funchook
- git -C layer/subprojects/funchook submodule init distorm
+ git submodule init
+ git config submodule.layer/funchook.url "$srcdir/funchook"
+ git config submodule.layer/subprojects/perfetto.url "$srcdir/perfetto"
+ git config submodule.layer/unity/unhollowed.url "$srcdir/unhollowed-assemblies"
+ git -c protocol.file.allow=always submodule update
+
+ git -C layer/subprojects/funchook submodule init
git -C layer/subprojects/funchook config submodule.distorm.url "$srcdir/distorm"
- git -C layer/subprojects/funchook submodule update distorm
+ git -c protocol.file.allow=always -C layer/subprojects/funchook submodule update
}
build() {