summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorHans-Nikolai Viessmann2021-02-17 11:51:29 +0100
committerHans-Nikolai Viessmann2021-02-17 11:51:29 +0100
commite74e01d21baf5ddac042e3611e0d42acd343a164 (patch)
tree1cdad393dfb7482fb8a5399e2aa0f1e9b8da23c8 /PKGBUILD
parentcf2ee17f18f906549801fb8eb75fbbb515eb773c (diff)
downloadaur-latex-saxpsa-ok.tar.gz
fix T1 formatting
For some reason, the original designer set this to OT1, which is not correct as the PFB is set to use 256 bytes which is only supported in T1. I've rewritten the font description file, which should all this font to be correctly loaded.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 15 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 45bfe7793e64..65fcc48b5927 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
_pkgname=saxpsa
pkgname=latex-${_pkgname}-ok
pkgver=13.03.2007
-pkgrel=6
+pkgrel=7
pkgdesc="Provides Type 1 font compatible with displaying APL."
arch=('any')
url="http://olegykj.sourceforge.net/"
@@ -15,21 +15,28 @@ md5sums=('4d9fdeb829303fdcde2d9cce9a8e69d4'
'64399e8274fbbc4d8cb3f18f5af62d8c'
'611ca8dc62dc619604afc0be0fe13cb8')
-package() {
- # create dir for STY and OT1 font files
- install -d ${pkgdir}/usr/share/texmf/tex/latex/${_pkgname}/
+prepare () {
+ cd ${srcdir}/${_pkgname}
+
+ # rename map file, pdftex.map is otherwise a protected name
+ mv texmf/fonts/map/pdftex/${_pkgname}/{pdftex.map,${_pkgname}.map}
+
+ # switch to actual T1 specification
+ mv OT1saxpsa.fd T1saxpsa.fd
+ sed -i -e 's/OT1/T1/g' T1saxpsa.fd ${_pkgname}.sty
+}
+package() {
# copy over font files
+ install -d ${pkgdir}/usr/share/texmf/tex/latex/${_pkgname}/
cp -r --no-preserve=mode ${_pkgname}/texmf ${pkgdir}/usr/share/
# copy over STY & OT1 definition
cp --no-preserve=mode ${_pkgname}/${_pkgname}.sty ${pkgdir}/usr/share/texmf/tex/latex/${_pkgname}/
- cp --no-preserve=mode ${_pkgname}/OT1saxpsa.fd ${pkgdir}/usr/share/texmf/tex/latex/${_pkgname}/
+ cp --no-preserve=mode ${_pkgname}/T1saxpsa.fd ${pkgdir}/usr/share/texmf/tex/latex/${_pkgname}/
- # create dir for global MAPS file
+ # create dir and copy global MAPS file
install -d ${pkgdir}/var/lib/texmf/arch/installedpkgs/
-
- # copy MAPS file
cp --no-preserve=mode "${_pkgname}.maps" ${pkgdir}/var/lib/texmf/arch/installedpkgs/
# set license