summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJoão Figueiredo2023-06-10 01:05:23 +0100
committerJoão Figueiredo2023-06-10 01:05:23 +0100
commit36db47e8fe267fb1293bc45c49aa6918853a46f2 (patch)
tree34cebe681cb7dc3b293ff265957359d9098c987c /PKGBUILD
parent62359eccf3280d41819d6234974560d6fc9e4e29 (diff)
downloadaur-layer-shell-qt-git.tar.gz
Migrate to Qt6
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD5
1 files changed, 3 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 721d687d6733..401275d5e774 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,13 @@
# Maintainer: João Figueiredo & chaotic-aur <islandc0der@chaotic.cx>
pkgname=layer-shell-qt-git
-pkgver=5.22.80_r41.g9af3c35
+pkgver=5.27.80_r94.g3bfed84
pkgrel=1
pkgdesc='Qt component to allow applications to make use of the Wayland wl-layer-shell protocol'
arch=($CARCH)
url='https://invent.kde.org/plasma/layer-shell-qt'
license=(LGPL)
-depends=(qt5-wayland)
+depends=(qt6-wayland)
makedepends=(git extra-cmake-modules-git wayland-protocols)
conflicts=(${pkgname%-git})
provides=(${pkgname%-git})
@@ -23,6 +23,7 @@ pkgver() {
build() {
cmake -B build -S ${pkgname%-git} \
+ -DQT_MAJOR_VERSION=6 \
-DBUILD_TESTING=OFF
cmake --build build
}