summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDimitris Kiziridis2020-07-04 00:24:34 +0300
committerDimitris Kiziridis2020-07-04 00:24:34 +0300
commit0af2e8afa47149548eb4ab3af3551d82c1da9df2 (patch)
tree42d9b5142a6ae14eacada1f77d227791699514d1 /PKGBUILD
downloadaur-lazagne.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6ad039fba785
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Dimitris Kiziridis <ragouel at outlook dot com>
+
+pkgname=lazagne
+pkgver=2.4.3
+pkgrel=1
+pkgdesc='An open source application used to retrieve lots of passwords stored on a local computer'
+arch=('any')
+url="https://github.com/AlessandroZ/LaZagne"
+license=('LGPL3')
+depends=('python-psutil'
+ 'python-secretstorage'
+ 'python-pyasn1'
+ 'python-pycryptodome'
+ 'python-pypykatz'
+ 'python-rsa')
+makedepends=('python-setuptools')
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/AlessandroZ/LaZagne/archive/${pkgver}.tar.gz")
+sha256sums=('2057ec5697f44556dcc5d42321fa70244343859571f5ac98ad3e48a8ac44a90b')
+
+package() {
+ cd "LaZagne-${pkgver}"
+ install -d "${pkgdir}/opt/"
+ cp -R Linux "${pkgdir}/opt/LaZagne"
+ install -d "${pkgdir}/usr/bin/"
+ ln -s /opt/LaZagne/laZagne.py "${pkgdir}/usr/bin/lazagne"
+ install -Dm644 README.md -t "${pkgdir}/usr/share/doc/${pkgname}"
+ install -Dm644 CHANGELOG -t "${pkgdir}/usr/share/doc/${pkgname}"
+} \ No newline at end of file