summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorĐức Nam Trần2016-03-26 15:18:54 +0700
committerĐức Nam Trần2016-03-26 15:18:54 +0700
commit6cbc563db15b068965c1ffab337d3ce313520af1 (patch)
treee1970e3fa9b6ab6224b51e541a751f491f34ada0 /PKGBUILD
downloadaur-ldoce5viewer-git.tar.gz
Clone from AUR bot and add patch to run with python-whoosh 2.7
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD40
1 files changed, 40 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a98c7ac48e09
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+_reponame=ldoce5viewer
+pkgname="${_reponame}-git"
+pkgver=r43.8004fb9
+pkgrel=1
+pkgdesc="Fast dictionary viewer for the Longman Dictionary of Contemporary English (LDOCE) 5th Edition"
+url="http://hakidame.net/ldoce5viewer/"
+license=(GPL3)
+arch=('any')
+depends=(git python-pyqt4 python-lxml gstreamer0.10-python gstreamer0.10-good-plugins gstreamer0.10-ugly-plugins python-whoosh phonon-qt4)
+install="${_reponame}"-git.install
+source=("git://github.com/ciscorn/ldoce5viewer.git" "whoosh2.7.patch")
+sha512sums=('SKIP' "SKIP")
+
+pkgver() {
+ cd "${srcdir}/${_reponame}"
+
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "${srcdir}/${_reponame}"
+
+ make build
+}
+
+package() {
+ cd "${srcdir}/${_reponame}"
+
+ patch -p1 < ../whoosh2.7.patch
+ python setup.py install --optimize=1 --root="${pkgdir}"
+ install -Dm644 "ldoce5viewer/qtgui/resources/ldoce5viewer.svg" \
+ "${pkgdir}/usr/share/pixmaps/ldoce5viewer.svg"
+ install -Dm644 "ldoce5viewer.desktop" \
+ "${pkgdir}/usr/share/applications/ldoce5viewer.desktop"
+ install -Dm644 "LICENSE.txt" \
+ "${pkgdir}/usr/share/licenses/$pkgname/LICENSE.txt"
+ install -Dm644 "COPYING.txt" \
+ "${pkgdir}/usr/share/licenses/$pkgname/COPYING.txt"
+}
+