summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorfossdd2021-06-25 15:18:24 +0000
committerfossdd2021-06-25 15:18:24 +0000
commit25ec4a9e302861276694e645eca91beb741385ea (patch)
tree9163b5871318dbeef53892b091c67cb54d1a53d3 /PKGBUILD
downloadaur-lesbar-git.tar.gz
initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2f102dd0ec53
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: fossdd <fossdd@tutanota.com>
+pkgname=lesbar-git
+_pkgname=${pkgname%-git}
+pkgver=0.4
+pkgrel=1
+pkgdesc="Markup language for status bars"
+arch=('x86_64')
+url="https://git.sr.ht/~salmiak/lesbar"
+license=('MIT')
+depends=('cairo'
+ 'glib2'
+ 'pango'
+ 'libx11')
+makedepends=('scdoc')
+source=("git+https://git.sr.ht/~salmiak/$_pkgname")
+md5sums=("SKIP")
+
+build() {
+ cd "$_pkgname"
+ make
+}
+
+package() {
+ cd "$_pkgname"
+ make DESTDIR="$pkgdir/" PREFIX="usr" install
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}