summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authororumin2017-07-09 13:30:34 +0900
committerorumin2017-07-09 13:30:34 +0900
commit3bc7ad722b4fa93f5440ab7ec9baccbecef1fd29 (patch)
treed52aae7a786766cd5b5e26d5f76479d81f523b19 /PKGBUILD
parent5917ed1d44545aaca6874537af27d380ef662a18 (diff)
downloadaur-3bc7ad722b4fa93f5440ab7ec9baccbecef1fd29.tar.gz
version bump
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD38
1 files changed, 27 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b6a67b1f4d49..03c33b1ebf79 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
_basename=gst-plugins-ugly
pkgname="lib32-$_basename"
-pkgver=1.8.3
+pkgver=1.12.1
pkgrel=1
pkgdesc="GStreamer Multimedia Framework Ugly Plugins (32-bit)"
arch=('x86_64')
@@ -10,23 +10,39 @@ license=('LGPL')
url="https://gstreamer.freedesktop.org/"
depends=('lib32-gst-plugins-base-libs' 'lib32-libdvdread' 'lib32-lame' 'lib32-libmpeg2' 'lib32-a52dec' 'lib32-libmad' 'lib32-libsidplay'
'lib32-libcdio' 'lib32-libx264' 'lib32-opencore-amr' 'lib32-mpg123' 'gst-plugins-ugly')
-makedepends=('python' 'x264')
-options=(!emptydirs)
-source=(${url}/src/$_basename/$_basename-$pkgver.tar.xz)
-sha256sums=('6fa2599fdd072d31fbaf50c34af406e2be944a010b1f4eab67a5fe32a0310693')
+makedepends=('python' 'lib32-libx264' 'autoconf-archive' 'git' 'valgrind-multilib')
+_commit=53e145066bd6302f041880f2450d7549768d1976 # tags/1.12.1^0
+source=("git+https://anongit.freedesktop.org/git/gstreamer/gst-plugins-ugly#commit=$_commit"
+ "gst-common::git+https://anongit.freedesktop.org/git/gstreamer/common")
+sha256sums=('SKIP'
+ 'SKIP')
+pkgver() {
+ cd $_basename
+ git describe --tags | sed 's/-/+/g'
+}
+
+prepare() {
+ cd $_basename
+
+ git submodule init
+ git config --local submodule.common.url "$srcdir/gst-common"
+ git submodule update
+
+ NOCONFIGURE=1 ./autogen.sh
+}
build() {
- cd $_basename-$pkgver
+ cd $_basename
export CC='gcc -m32'
export CXX='g++ -m32'
export PKG_CONFIG_PATH='/usr/lib32/pkgconfig'
- ./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var \
+ ./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var --libexecdir=/usr/lib32 \
--build=i686-pc-linux-gnu --libdir=/usr/lib32 \
- --disable-static --enable-experimental --disable-gtk-doc \
--with-package-name="GStreamer Ugly Plugins (Arch Linux)" \
- --with-package-origin="http://www.archlinux.org/"
+ --with-package-origin="http://www.archlinux.org/" \
+ --disable-static --enable-experimental --disable-gtk-doc
# https://bugzilla.gnome.org/show_bug.cgi?id=655517
sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
@@ -35,12 +51,12 @@ build() {
}
check() {
- cd $_basename-$pkgver
+ cd $_basename
make check
}
package() {
- cd $_basename-$pkgver
+ cd $_basename
make DESTDIR="${pkgdir}" install
rm -r "$pkgdir"/usr/share